0 Replies Latest reply on May 18, 2012 8:45 AM by Horst Leitenmueller

    JBoss 6.1.0.Final build from source fails with jboss-ejb3-embedded-impl-as:jar not found.

    Horst Leitenmueller Newbie

      hi all,

       

      i have a question regarding the build of JBoss 6.1.0.Final from source,

      downloaded the http://download.jboss.org/jbossas/6.1/jboss-as-distribution-6.1.0.Final-src.zip

       

      and tried to build;

       

      unzip jboss-as-distribution-6.1.0.Final-src.zip

      cd ./jboss-6.1.0.Final-src

      ant -buildfile build/build.xml   (with default target)

       

      results in

       

      jboss-6.1.0.Final-src/build/build.xml:685: Reference org.jboss.ejb3.embedded:jboss-ejb3-embedded-impl-as:jar not found.

       

      now my question is this working for somebody ?

       

      tried it on FreeBSD 8.2 with openjdk6 and MacOSX 10.6

       

      br horst

       

      info: maven build is running through this is module packaging...

       

           [java] [INFO] ------------------------------------------------------------------------

           [java] [INFO] BUILD SUCCESS

           [java] [INFO] ------------------------------------------------------------------------

           [java] [INFO] Total time: 4:03.413s

           [java] [INFO] Finished at: Fri May 18 14:38:42 CEST 2012

           [java] [INFO] Final Memory: 219M/458M

           [java] [INFO] ------------------------------------------------------------------------

           [java] [WARNING] The requested profile "skip-dist" could not be activated because it does not exist.

       

       

      module-ejb3:

       

       

      BUILD FAILED

      /Users/horst/Downloads/jboss-6.1.0.Final-src/build/build.xml:685: Reference org.jboss.ejb3.embedded:jboss-ejb3-embedded-impl-as:jar not found.