4 Replies Latest reply on May 28, 2012 11:03 AM by antonio vasquez

    Installation issue of jBPM5

    Namitha TM Newbie

      I am trying to install jBPM. I am doing this by refering the the user guide http://docs.jboss.org/jbpm/v5.2/userguide/ch03.html

      I have installed java and ant by using the link specified in the user guide.

      I am using 64 bit Windows 7 and I installed java jdk-7u4-windows-x64.exe and it's location is C:\Program Files\Java\jdk1.7.0_04.

      Downloaded apache-ant-1.8.3-bin.zip and unzip to the location D:\ant

      I have created two external variables JAVA_HOME and ANT_HOME and specified the following path

      JAVA_HOME :C:\Program Files\Java\jdk1.7.0_04

      ANT_HOME:D:\ant

      Path:C:\Program Files\Java\jdk1.7.0_04\bin;C:\Program Files (x86)\Java\jre7\bin;C:\Program Files (x86)\Java\jre7\lib;%ANT_HOME%/bin;%JAVA_HOME%/bin

      On command Prompt

      D:\> java -version   is working perfectly. (Its showing java version "1.7.0_04")

      If I put the following command

      D:\ant>ant 

      Buidfile:D;\ant\buil.xml

      build:

                [javac]D:\ant\build.xml:12:warning:'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds

      BUILD SUCCESSFUL

      Total time: 2 seconds

       

       

      After that I downloaded the jbpm-5.2.0.Final-installer-full.zip (309.2 MB) and unzip to D drive

      On command prompt

      D:\jbpm-installer>ant install.demo

      Its downloading everything but its stopped when it reached downloading eclipse

      download.eclipse:

                [echo] Geting Eclipse ...

                [get] Getting: http://download.eclipse.org/technology/epp/downloads/release/helios/eclipse-java-helios-SR2-win32.zip

                [get] To: D:\jbpm-installer\lib\eclipse-java-helios-SR2-win32.zip

      The command stopped here

       

       

      Eclipse is downloaded but cant unzip it .when i trying to unzip it manually, it shows the following error :

      - An alert that "No archieve found"

      and also shows Cannot open D:\jbpm-installer\lib\eclipse-java-helios-SR@-win32.zip

       

       

      And I downloaded eclipse-java-helios-SR2-win32-x86_64.zip from http://mirror.bit.edu.cn/eclipse/technology/epp/downloads/release/helios/SR2/eclipse-java-helios-SR2-win32-x86_64.zip. When i try to unzip, it shows , the archieve is unknown format or damaged.

       

       

      There is another eclipse "C:\Program Files (x86)\eclipse-jee-galileo-SR1-win32" in the system and it is working perfectly

       

       

      Any Idea?

        • 1. Re: Installation issue of jBPM5
          Bhaskaran Venkataraman Newbie

          Hi,

           

          The Eclipse download takes some time as it is around 200 MB. It also depends on your internet connection. For instance if you have a 200 KBPS connection it could take hours

          to download. You can download eclipse separately and then you can remove it from the build script ( build.xml ). The build.properties file sets the eclipse home. You have to change

          it to wherever you have downloaded eclipse. That's what I did and it works perfectly fine.

           

          I was able to download the helios version mentioned in the build script ( build.xml ) without any issues. I was able to download eclipse within minutes at work because of the fast internet connection. But I have experienced problems downloading eclipse & some of its plugins at home because of slower internet connection.

           

          Hope this helps.

          • 2. Re: Installation issue of jBPM5
            chandrasachin16 Newbie

            Hi Namitha,

             

            This occured because the internet connection was slow so the eclipse zip file you downloaded was not complete .So it was corrupted.I faced  the same problem and tried to re-download and it worked.If that also does not work .You can use any eclipse which is already istalled on your system and configure it for JBPM by installing the necessary plugins. You can extract the zip file(org.drools.updatesite-5.3.1.Final-assembly) that comes with JBPM full installer zip file.You will find two folders plugins and features .Copy the corresponding jar files and paste it in your eclipse's plugins and featues folder and restart your eclipse.

            • 3. Re: Installation issue of jBPM5
              Namitha TM Newbie

              Thanks All. It was some java related issues. It's working now.

              • 4. Re: Installation issue of jBPM5
                antonio vasquez Newbie

                good morning, my name is antonio vasquez'm installing helios eclipse tool but fails to install either the import of projects that the default application that brings the sample directory of jbpm-installer. please I need help.
                thanks