2 Replies Latest reply on May 23, 2012 10:37 AM by msavy

    Missing `gem_original_require'

    tiradani Newbie

      Hi,

       

      I am trying to install Boxgrinder on SL6.  I basically followed the instructions from http://blog.frameos.org/2011/11/11/installing-boxgrinder-in-rhelcentos-6-distributions/.

       

      The problem is that when I execute boxgrinder-build, I get the following errors:

       

      /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- libvirt (LoadError)

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'

          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.1/lib/boxgrinder-build/plugins/delivery/libvirt/libvirt-capabilities.rb:19

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'

          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.1/lib/boxgrinder-build/plugins/delivery/libvirt/libvirt-plugin.rb:20

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'

          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.1/lib/boxgrinder-build/helpers/plugin-helper.rb:29

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'

          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.1/lib/boxgrinder-build/appliance.rb:26

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'

          from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'

          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.1/bin/boxgrinder-build:27

          from /usr/bin/boxgrinder-build:19:in `load'

          from /usr/bin/boxgrinder-build:19

       

      Any ideas on how to fix this?

       

      Thanks!