10 Replies Latest reply on Aug 8, 2012 10:14 AM by jaikiran pai

    changes are not reflecting on browser using jboss

    Avneesh Sisodia Newbie

      Hello all,

      I am facing a problem in JBoss AS 7.0.0. When I am doing any changes in project's file either it is jsp, xhtml or css relative changes are not reflecting on browser where I am seeing output of code. It is basically mavenized seam project and I am using Eclipse for development. Is there any process to get fix this problem. I think this problem is because of JBoss Server. Please help me to resolve this problem...

        • 1. Re: changes are not reflecting on browser using jboss
          jaikiran pai Master

          See https://community.jboss.org/message/620397#620397.

           

          By the way, I would recommend that you move to 7.1.1.Final instead of 7.0.x

          • 2. Re: changes are not reflecting on browser using jboss
            Avneesh Sisodia Newbie

            thanks jaikiran

            I did changes in standalone.xml as given in

            https://community.jboss.org/message/620397#620397  link but it is not working for me. And I can't migrate Jboss version from AS 7.0.0 to 7.1.x. I have to resolve this problem in 7.0.0 version.

            • 3. Re: changes are not reflecting on browser using jboss
              jaikiran pai Master

              You won't be able to get this to work in 7.0.0 since it was a bug in that version which was fixed in 7.0.1 https://issues.jboss.org/browse/AS7-1509

              • 4. Re: changes are not reflecting on browser using jboss
                Avneesh Sisodia Newbie

                Actually there are some problems in migration of version.

                I am using seam 2.2 and I had modified datasurces in standalone.xml to fix my seam project. When all those changes I am doing in jboss 7.1.1 , server is not starting it gives error ..

                 

                16:59:22,979 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA

                16:59:23,401 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA

                16:59:23,464 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting

                16:59:24,386 ERROR [org.jboss.as.server] JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration

                    at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                    at org.jboss.as.server.ServerService.boot(ServerService.java:266) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                    at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:155) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                    at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_25]

                Caused by: javax.xml.stream.XMLStreamException: org.jboss.as.connector.util.ParserException: IJ010061: Unexpected element: useFastFail

                    at org.jboss.as.connector.subsystems.datasources.DataSourcesExtension$DataSourceSubsystemParser.readElement(DataSourcesExtension.java:784)

                    at org.jboss.as.connector.subsystems.datasources.DataSourcesExtension$DataSourceSubsystemParser.readElement(DataSourcesExtension.java:333)

                    at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                    at org.jboss.staxmapper.XMLExtendedStreamReaderImpl.handleAny(XMLExtendedStreamReaderImpl.java:69) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                    at org.jboss.as.server.parsing.StandaloneXml.parseServerProfile(StandaloneXml.java:894) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                    at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_1(StandaloneXml.java:330) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                    at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:127) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                    at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:100) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                    at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                    at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                    at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                    ... 3 more

                Caused by: org.jboss.as.connector.util.ParserException: IJ010061: Unexpected element: useFastFail

                    at org.jboss.as.connector.subsystems.datasources.DsParser.parseValidationSetting(DsParser.java:1017)

                    at org.jboss.as.connector.subsystems.datasources.DsParser.parseDataSource(DsParser.java:710)

                    at org.jboss.as.connector.subsystems.datasources.DsParser.parseDataSources(DsParser.java:194)

                    at org.jboss.as.connector.subsystems.datasources.DsParser.parse(DsParser.java:165)

                    at org.jboss.as.connector.subsystems.datasources.DataSourcesExtension$DataSourceSubsystemParser.readElement(DataSourcesExtension.java:776)

                    ... 13 more

                 

                16:59:24,464 FATAL [org.jboss.as.server] JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.

                16:59:24,495 INFO  [org.jboss.as] JBAS015950: JBoss AS 7.1.1.Final "Brontes" stopped in 2ms

                 

                 

                 

                just because of this reason i want to use jboss 7.0.0.

                • 5. Re: changes are not reflecting on browser using jboss
                  jaikiran pai Master

                  Caused by: javax.xml.stream.XMLStreamException: org.jboss.as.connector.util.ParserException: IJ010061: Unexpected element: useFastFail

                  Change that to

                   

                  <use-fail-fast>WhateverValueYouWantToSet</use-fail-fast>

                   

                  I kind of remember there was a non-backward compatible change around this long time back.

                  1 of 1 people found this helpful
                  • 6. Re: changes are not reflecting on browser using jboss
                    Avneesh Sisodia Newbie

                    Thanks Jaikiran,

                    I did that change. And server is working fine.But my problem is still there. Changes are not showing on browser.

                    • 7. Re: changes are not reflecting on browser using jboss
                      jaikiran pai Master

                      Avneesh Sisodia wrote:

                       

                      I did that change. And server is working fine.But my problem is still there. Changes are not showing on browser.

                      It's broken in 7.1.1.Final too (and I forgot about it) https://issues.jboss.org/browse/AS7-4187 So here are your options:

                       

                      1) Use 7.1.0.Final (where I think this isn't an issue)

                      2) Or use the latest nightly builds available here https://community.jboss.org/thread/167590

                      3) Or wait for the next release of AS7 (I don't know the date).

                      1 of 1 people found this helpful
                      • 8. Re: changes are not reflecting on browser using jboss
                        Avneesh Sisodia Newbie

                        Thanks fo this information Jaikiran....Is there any other plugin which may be helpful to do this. I mean something which can be integrate with jboss and can do this..

                        • 9. Re: changes are not reflecting on browser using jboss
                          Avneesh Sisodia Newbie

                          Hi Jiakiran,

                          I used Latest "JBoss AS 7.1" Final today. But I am still failed to get positive result from this latest relaese of Server. I am not able to see changes done in jsp during project is running in developmet mode.

                          • 10. Re: changes are not reflecting on browser using jboss
                            jaikiran pai Master

                            Avneesh Sisodia wrote:

                             

                            Hi Jiakiran,

                            I used Latest "JBoss AS 7.1" Final today.

                            You mean 7.1.1.Final? As already noted in my reply, that version has the bug.