0 Replies Latest reply on May 29, 2012 10:29 AM by jjaannrr

    Cannot deploy OSGi fragments into JBOSS 7.1.2

    jjaannrr Newbie

      Hi All,

       

      I'm trying to deploy SLF4J bundles, which make use of OSGi fragments. I cannot get it working in JBOSS 7.1.2. I had a problem in 7.1.1 which I though was related to AS7-4183.

      In 7.1.2 the deployment fails with

      15:18:54,100 INFO  [org.jboss.osgi.framework] (MSC service thread 1-3) JBOSGI011001: Bundle installed: slf4j.jdk14:1.6.4

      15:18:54,146 INFO  [org.jboss.osgi.framework] (MSC service thread 1-1) JBOSGI011001: Bundle installed: slf4j.api:1.6.4

      15:18:54,162 INFO  [org.jboss.osgi.framework] (MSC service thread 1-3) JBOSGI011001: Bundle installed: jboss-osgi-logging:1.0.0

      15:18:54,178 INFO  [org.jboss.osgi.framework] (MSC service thread 1-2) JBOSGI011001: Bundle installed: org.apache.felix.configadmin:1.2.8

      15:18:54,193 INFO  [org.jboss.osgi.framework] (MSC service thread 1-3) JBOSGI011001: Bundle installed: jboss-as-osgi-configadmin:7.1.2.Final

      15:18:54,209 INFO  [org.jboss.osgi.framework] (MSC service thread 1-1) JBOSGI011001: Bundle installed: org.apache.felix.log:1.0.0

      15:18:54,225 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014775:    New missing/unsatisfied dependencies:

            service jbosgi.integration.AutoInstallHandler.COMPLETE (missing) dependents: [service jbosgi.integration.PersistentBundlesHandler, service jbosgi.framework.INIT]

       

       

      I get the same error when trying to deploy my own test OSGi fragments.

       

      Anyone having the same problem? I'm sure it worked in previous 7.x versions as I was able to deploy slf4j as part of Apache CXF DOSGi.

       

       

      Jan