2 Replies Latest reply on Jun 11, 2012 9:49 AM by dgr

    Eclipse, ESB 4.11 and remote ServiceInvoker problems

    dgr Newbie

      Hi all

      I have some problems with Eclipse 3.6, ESB 4.11, JBoss AS 6.1.0 on Linux OpenSuse 11.4 x64 with java jdk 1.6.0 x64. When I try to build and deploy quickstarts projects in jbossesb-4.11/samples/, with "ant deploy", all is ok and samples run. But when I try to start with an Eclipse project, for example one based on "helloword", with ServiceInvoker class I get the following unbearable exception:

      Exception in thread "main" org.jboss.soa.esb.listeners.message.MessageDeliverException: org.apache.ws.scout.transport.TransportException: java.lang.reflect.InvocationTargetException

      1. etc.

      Ok, no problem. I have not experience with JBoss ESB and with so much patience, I start looking for a solution in web. Soon I realized that the problem seems common. I have done everything that is written here (the problem seems the same): https://community.jboss.org/thread/144658, but nothing: no results. Then I have read carefully "Configuration for a Remote Service Invoker" in "ESB Programmers Guide", but still no results.

      My code is very simple:

       

      System.setProperty("javax.xml.registry.ConnectionFactoryClass","org.apache.ws.scout.registry.ConnectionFactoryImpl");
      Message message = MessageFactory.getInstance().getMessage();    
      message.getBody().add("test test test");
      ServiceInvoker serviceInvoker = new ServiceInvoker("FirstServiceESB", "SimpleListener");
      serviceInvoker.deliverAsync(esbMessage);

       

      The exception borns when I try to call new ServiceInvoker. I'm sure that the problems are in classpath, but the jar listed in https://community.jboss.org/thread/144658 and in "Configuration for a Remote Service Invoker" are all in my classpath; also I have checked the base-build.xml ant script and in my Eclipse project all seems correct. Also in the Eclipse project there are "JBoss ESB Runtime" and "JBoss 6 Runtime" library references; uddi.xml, jbossesb-properties.xml, etc. are all in my classpath or in my META-INF folder. Finally, after dozens of attempts, not knowing what to do and with no other resources, I tried to run my code with jdk x86 (jdk 1.6.22), but nothing, no results, of course.

      Is there anyone that can help me?

       

      Regards

      Daniele

        • 1. Re: Eclipse, ESB 4.11 and remote ServiceInvoker problems
          Tom Cunningham Master

          Daniele,

           

          The ServiceInvoker definitely works with JBoss AS 6.1.0 - for example if you deploy the helloworld quickstart, and then run

           

          ant sendesb

           

          you are executing the Service Invoker remotely.     I'm not sure how much help that gives you given the wide classpath net that that casts, but it at least proves that this is working.

           

          The list in the thread and the "Configuration for a Remote Service Invoker" are all 5.1.0.GA based.     For 6.1.0.Final, you may need to add a few JARs here and there, or change versions to match what's in 6.1.0.Final.      Other concerns would be what JMS are you using - are you using JBoss Messaging (the default)?   Or have you switched to hornetq?     If you've switched to hornetq, you'd need to add the hornetq-jms and hornetq-core-client.

           

          My suggestion would be to go through your list of JARs and compare them with the versions in 6.1.0.Final.    If they differ, try bringing over the 6.1.0.Final version.     If that still doesn't help you, write back and I'll try to help you come up with the list of JARs you need.

           

          --Tom

          1 of 1 people found this helpful
          • 2. Re: Eclipse, ESB 4.11 and remote ServiceInvoker problems
            dgr Newbie

            Hi Tom

            Thanks for your reply; since nobody had answered to my help request, I have worked around the problem with an ant compile and deploy project. Then, after that,  I have the suspect that my problem is not an error in classpath or libraries, but it is perhaps in my Eclipse plugin for JBoss AS configuration (I am new with the JBoss technology...). In fact a simple dynamic web project does not work, even if all the files are deployed in the temp deploy directory of my Jboss AS 6.1. In my Eclipse 3.6, the JBoss AS plugin is for JBoss AS 6.0, but not for JBoss AS 6.1 and the “Problems” windows of my Eclipse report this as a problem.

             

            Daniele