0 Replies Latest reply on Jun 5, 2012 12:15 PM by Dmitri Zamysloff

    CDI + REST Problem

    Dmitri Zamysloff Newbie

      Hi All,

      i have encountered a problem to deploy web application (.war) which includes rest services and cdi. It seems that the Weld does not scan jars. I have standalone tomcat weld resteasy application and it works. But not in AS7. The build of war as follows:

      war

      |- WEB-INF

              |- beans.xml                                -> just <beans></beans>

               |- web.xml                                   -> nothing special just marker for REST

               |- jboss-deployment-structure.xml -> dependencies

               |- jbsoss-web.xml                        -> context path, realm name, ds mappings

               \- lib

                   | ...... jars

                  |- somename1.jar                    -> defines interceptors, binding annotations, producers

                   |          \- META-INF

                   |                  \- beans.xml         -> lists all interceptors

                  |

                   \- somename2.jar                    -> uses Injections (from producers above), annotations defined in jar above.

                              \- META-INF

                                     \- beans.xml         -> just <beans></beans> to show that it must be controlled.

       

      As I say in standalone app it is working. But not in AS7. Everything up to my CDI interceptors works. Interceptors will be ignored. I see following in log:

      17:55:43,783 INFO  [org.jboss.weld.deployer] (MSC service thread 1-2) JBAS016005: Starting Services for CDI deployment: my.war

      17:55:43,814 INFO  [org.jboss.weld.Version] (MSC service thread 1-2) WELD-000900 1.1.5 (AS71)

      17:55:43,860 INFO  [org.jboss.weld.deployer] (MSC service thread 1-1) JBAS016008: Starting weld service for deployment my.war

      Nothing more. Ah also this:

      [org.jboss.resteasy.cdi.CdiInjectorFactory] (http--127.0.0.1-8080-1) Found BeanManager at java:comp/BeanManager

       

      What I was expecting to see is some trace of interceptors.

       

      Any ideas? What I am doing wrong? Thank you very much in advance!