2 Replies Latest reply on Jun 7, 2012 5:40 PM by Aleš Bregar

    Long shutdown time of JBoss AS 7.1.2.Final "Steropes" (stopped in 181035ms)

    Aleš Bregar Newbie

      Hi,

       

       

      I am into a problem at shutdown of my app. Looks like that something locks tomcat for very long time and I would be glad to hear a hint what might be wrong(configuration?). In the thread_stack_at_shutdown.txt is a thread snapshot at some moment during this long shutdown period. Also sometimes (not always - wonder why?) the exception  - Malformed_reply_from_SOCKS.txt - can be seen in logs.

       

      Thank you very much in advance,

      A

        • 1. Re: Long shutdown time of JBoss AS 7.1.2.Final "Steropes" (stopped in 181035ms)
          Tomaz Cerar Master

          Hi Aleš,

           

          how does your web subsystem configuration looks like?

           

           

           

          --

          tomaz

          • 2. Re: Long shutdown time of JBoss AS 7.1.2.Final "Steropes" (stopped in 181035ms)
            Aleš Bregar Newbie

            Hi Tomaz,

             

            tnx on looking into this. So this is my current best conf:

             

            <configuration>
                <jsp-configuration development="true" smap="false" disabled="false" keep-generated="true" trim-spaces="false" tag-pooling="true" mapped-file="true" check-interval="1" modification-test-interval="4" recompile-on-fail="false"  dump-smap="false" generate-strings-as-char-arrays="true" error-on-use-bean-invalid-class-attribute="true" scratch-dir="../standalone/tmp/" source-vm="1.6" target-vm="1.6" java-encoding="utf-8" x-powered-by="true" display-source-fragment="true"/>
            </configuration>
            <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http" redirect-port="8443" max-post-size="2048" executor="http-executor" max-connections="50000"/>
            <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true">
                <ssl name="foo-ssl" key-alias="foo" password="bar" certificate-key-file="../standalone/configuration/foo.keystore" protocol="TLSv1"/>
            </connector>
            <connector name="exApacheCon" protocol="HTTP/1.1" scheme="http" socket-binding="exApacheSb" />
            <connector name="exApacheConS" protocol="HTTP/1.1" scheme="https" socket-binding="exApacheSbS" secure="true">
                <ssl name="foo-ssl" key-alias="foo" password="bar" certificate-key-file="../standalone/configuration/foo.keystore" protocol="TLSv1"/>
            </connector>
            <virtual-server name="default-host" enable-welcome-root="true">
                <alias name="localhost"/>
                <rewrite pattern="^/leg/portal(.*)$" substitution="/dev$1" flags="NC"/>
            </virtual-server>
            

             

            but even if totally stripped the configuration to:

             

            <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http" />
                        <virtual-server name="default-host" enable-welcome-root="true">
                            <alias name="localhost"/>
                        </virtual-server>
            

             

            I have the same issue. I am starting to think it must be something in my app. Currently I am out of ideas how to go for this issue. Do you have any hint/idea?

             

            tnx,

            A