1 Reply Latest reply on Jun 26, 2012 12:13 AM by Vikas V

    JSF1053: (Listener: org.jboss.portletbridge.lifecycle.PortalPhaseListener.afterPhase(), Phase ID: RESTORE_VIEW 1,  View ID:

    Vikas V Newbie

      Hi,

       

      Am using Jboss AS 5.1.0 GA, JSF 1.2 , Rich faces 3.3

       

      My application gets deployed with no problem. But when I hit my web application, below warning is thrown and redirection from one link (within my page) to another page is not happening.

       

      faces-config.xml is configured as ,

       

      <?xml version="1.0" encoding="UTF-8"?>

      <faces-config version="1.2" xmlns="http://java.sun.com/xml/ns/javaee"

      xmlns:xi="http://www.w3.org/2001/XInclude"

      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-facesconfig_1_2.xsd">

       

       

      <application>

                <view-handler> org.jboss.portletbridge.application.PortletViewHandler </view-handler>

                <state-manager>org.jboss.portletbridge.application.PortletStateManager</state-manager>

      </application>

      </faces-config>

       

      In phase listener I have PhaseId.RENDER_RESPONSE .

       

      Below is the trace,

       

      WARNING [lifecycle] JSF1053: (Listener: org.jboss.portletbridge.lifecycle.PortalPhaseListener.afterPhase(), Phase ID: RESTORE_VIEW 1,  View ID: /jsp/index.xhtml) Exception thrown during phase-listener execution: java.lang.NullPointerException

      14:57:14,158 WARNING [lifecycle] org.jboss.portletbridge.lifecycle.PortalPhaseListener.afterPhase(PortalPhaseListener.java:59)

      com.sun.faces.lifecycle.Phase.handleAfterPhase(Phase.java:175)

      com.sun.faces.lifecycle.Phase.doPhase(Phase.java:114)

      com.sun.faces.lifecycle.RestoreViewPhase.doPhase(RestoreViewPhase.java:102)

      com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)

      ...............

       

       

      As per this post https://community.jboss.org/thread/176247 I have added the required configuration in faces-config.xml

       

      I have rich faces jars in lib folder.

       

      Please help.

       

      Thanks and regards,