7 Replies Latest reply on Jun 20, 2012 4:00 AM by meno priezvisko

    failed to compile marshaller class

    meno priezvisko Newbie

      Hi,

      I have downloaded a sample helloworld-errai application from https://github.com/jbossas/quickstart

       

      I have problem with it - when I deploy this application to JBoss AS 7.1.1.Final and when the page loads, I get the following error - see attachment, because it is over 550 lines long...

       

      what am I doing wrong? I thought that sample application should work out-of-box...

       

      thanks a lot

        • 1. Re: failed to compile marshaller class
          jaikiran pai Master

          Welcome to the forums!

           

          For the benefit of others reading this thread, I'll just paste a portion of that attached log here:

           

          13:58:49,392 WARN  [ErraiMarshalling] (http--127.0.0.1-8080-1) could not locate marshaller class. will attempt dynamic generation.
          13:58:49,408 INFO  [org.jboss.errai.marshalling.rebind.MarshallerGeneratorFactory] (http--127.0.0.1-8080-1) generating marshalling class...
          13:58:50,720 INFO  [org.jboss.errai.marshalling.rebind.MarshallerGeneratorFactory] (http--127.0.0.1-8080-1) generated marshalling class in 1312ms.
          13:58:51,767 INFO  [stdout] (http--127.0.0.1-8080-1) *** FAILED TO COMPILE MARSHALLER CLASS ***
          13:58:51,783 INFO  [stdout] (http--127.0.0.1-8080-1) *** Classpath Used: C:\work\jboss-as-7.1.1.Final\jboss-modules.jar;C:\work\jboss-as-7.1.1.Final\modules\com\sun\jsf-impl\main\jsf-impl-2.1.7-jbossorg-2.jar;C:\work\jboss-as-7.1.1.Final\modules\org\jboss\as\weld\main\jboss-as-weld-7.1.1.Final.jar;C:\work\jboss-as-7.1.1.Final\jboss-modules.jar
          13:58:51,783 INFO  [stdout] (http--127.0.0.1-8080-1) ----------
          13:58:51,783 INFO  [stdout] (http--127.0.0.1-8080-1) 1. ERROR in C:\DOCUME~1\user\LOCALS~1\Temp\errai\1abb52366cdabf38be9c215f49318cb476cfdd0622187d328c69729a595ae\errai.gen\classes\org\jboss\errai\marshalling\server\impl\ServerMarshallingFactoryImpl.java (at line 12)
          13:58:51,783 INFO  [stdout] (http--127.0.0.1-8080-1)     import org.jboss.errai.bus.client.api.base.MessageDeliveryFailure;
          13:58:51,783 INFO  [stdout] (http--127.0.0.1-8080-1)            ^^^^^^^^^^^^^^^^^^^
          13:58:51,798 INFO  [stdout] (http--127.0.0.1-8080-1) The import org.jboss.errai.bus cannot be resolved
          13:58:51,798 INFO  [stdout] (http--127.0.0.1-8080-1) ----------
          13:58:51,798 INFO  [stdout] (http--127.0.0.1-8080-1) 2. ERROR in C:\DOCUME~1\user\LOCALS~1\Temp\errai\1abb52366cdabf38be9c215f49318cb476cfdd0622187d328c69729a595ae\errai.gen\classes\org\jboss\errai\marshalling\server\impl\ServerMarshallingFactoryImpl.java (at line 13)
          13:58:51,798 INFO  [stdout] (http--127.0.0.1-8080-1)     import org.jboss.errai.bus.client.api.base.TransportIOException;
          13:58:51,798 INFO  [stdout] (http--127.0.0.1-8080-1)            ^^^^^^^^^^^^^^^^^^^
          13:58:51,798 INFO  [stdout] (http--127.0.0.1-8080-1) The import org.jboss.errai.bus cannot be resolved
          13:58:51,814 INFO  [stdout] (http--127.0.0.1-8080-1) ----------
          13:58:51,814 INFO  [stdout] (http--127.0.0.1-8080-1) 3. ERROR in C:\DOCUME~1\user\LOCALS~1\Temp\errai\1abb52366cdabf38be9c215f49318cb476cfdd0622187d328c69729a595ae\errai.gen\classes\org\jboss\errai\marshalling\server\impl\ServerMarshallingFactoryImpl.java (at line 14)
          13:58:51,814 INFO  [stdout] (http--127.0.0.1-8080-1)     import org.jboss.errai.marshalling.client.api.Marshaller;
          13:58:51,814 INFO  [stdout] (http--127.0.0.1-8080-1)            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          13:58:51,814 INFO  [stdout] (http--127.0.0.1-8080-1) The import org.jboss.errai.marshalling.client cannot be resolved
          13:58:51,814 INFO  [stdout] (http--127.0.0.1-8080-1) ----------
          13:58:51,830 INFO  [stdout] (http--127.0.0.1-8080-1) 4. ERROR in C:\DOCUME~1\user\LOCALS~1\Temp\errai\1abb52366cdabf38be9c215f49318cb476cfdd0622187d328c69729a595ae\errai.gen\classes\org\jboss\errai\marshalling\server\impl\ServerMarshallingFactoryImpl.java (at line 15)
          13:58:51,830 INFO  [stdout] (http--127.0.0.1-8080-1)     import org.jboss.errai.marshalling.client.api.MarshallerFactory;
          13:58:51,830 INFO  [stdout] (http--127.0.0.1-8080-1)            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          13:58:51,830 INFO  [stdout] (http--127.0.0.1-8080-1) The import org.jboss.errai.marshalling.client cannot be resolved
          13:58:51,830 INFO  [stdout] (http--127.0.0.1-8080-1) ----------
          13:58:51,830 INFO  [stdout] (http--127.0.0.1-8080-1) 5. ERROR in C:\DOCUME~1\user\LOCALS~1\Temp\errai\1abb52366cdabf38be9c215f49318cb476cfdd0622187d328c69729a595ae\errai.gen\classes\org\jboss\errai\marshalling\server\impl\ServerMarshallingFactoryImpl.java (at line 16)
          13:58:51,830 INFO  [stdout] (http--127.0.0.1-8080-1)     import org.jboss.errai.marshalling.client.api.MarshallingSession;
          13:58:51,845 INFO  [stdout] (http--127.0.0.1-8080-1)            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          13:58:51,845 INFO  [stdout] (http--127.0.0.1-8080-1) The import org.jboss.errai.marshalling.client cannot be resolved
          13:58:51,845 INFO  [stdout] (http--127.0.0.1-8080-1) ----------
          13:58:51,845 INFO  [stdout] (http--127.0.0.1-8080-1) 6. ERROR in C:\DOCUME~1\user\LOCALS~1\Temp\errai\1abb52366cdabf38be9c215f49318cb476cfdd0622187d328c69729a595ae\errai.gen\classes\org\jboss\errai\marshalling\server\impl\ServerMarshallingFactoryImpl.java (at line 17)
          13:58:51,845 INFO  [stdout] (http--127.0.0.1-8080-1)     import org.jboss.errai.marshalling.client.api.json.EJArray;
          13:58:51,845 INFO  [stdout] (http--127.0.0.1-8080-1)            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          .....
          
          13:58:52,767 INFO  [stdout] (http--127.0.0.1-8080-1) ----------
          13:58:52,767 ERROR [stderr] (http--127.0.0.1-8080-1) java.lang.NullPointerException
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.jboss.errai.marshalling.server.MappingContextSingleton.loadPrecompiledMarshallers(MappingContextSingleton.java:99)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.jboss.errai.marshalling.server.MappingContextSingleton.<clinit>(MappingContextSingleton.java:79)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.jboss.errai.bus.server.io.MessageFactory.getParts(MessageFactory.java:109)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.jboss.errai.bus.server.io.MessageFactory.createCommandMessage(MessageFactory.java:93)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.jboss.errai.bus.server.servlet.DefaultBlockingServlet.doPost(DefaultBlockingServlet.java:117)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:329)
          13:58:52,783 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:248)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.jboss.weld.servlet.ConversationPropagationFilter.doFilter(ConversationPropagationFilter.java:62)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:280)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:248)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:275)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:161)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:153)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:155)
          13:58:52,798 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          13:58:52,814 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
          13:58:52,814 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:368)
          13:58:52,814 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:877)
          13:58:52,814 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:671)
          13:58:52,814 ERROR [stderr] (http--127.0.0.1-8080-1)     at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:930)
          13:58:52,814 ERROR [stderr] (http--127.0.0.1-8080-1)     at java.lang.Thread.run(Thread.java:662)
          
          ...
          13:58:52,845 WARN  [ErraiMarshalling] (http--127.0.0.1-8080-1) failing over to dynamic marshallers ... performance may be affected.
          

           

           

          I don't know why those errors show up but I'll request someone who might know more about this, to take a look.

          • 2. Re: failed to compile marshaller class
            Stephen Coy Master

            For what it's worth, it works for me with both Java 1.7.0_04-b21 and 1.6.0_33-b03 on JBoss AS 7.1.1.Final on MacOS X.

             

            Are you building/deploying from an IDE or a commandline?

            • 3. Re: failed to compile marshaller class
              meno priezvisko Newbie

              IDE - Idea IntellJ

              I use maven to build and deploy - I follow intructions provided here:

              https://github.com/jbossas/quickstart/tree/master/helloworld-errai

               

              //EDIT the error occurs a few moments after the page is loaded - or simply press the button on the page

              • 4. Re: failed to compile marshaller class
                Stephen Coy Master

                Are you running a "virgin" copy of JBoss AS 7.1.1 (as opposed to one you've been experimenting on for a while)?

                • 5. Re: failed to compile marshaller class
                  sgilda Newbie

                  I just tried this quickstart again and it deploys and runs with no errors.

                   

                  To clarify:

                  You start your server in a terminal outside the IDE with the command 'bin/standalone.sh' or 'bin\standalone.bat' ?

                  You run this Maven command in a terminal outside the IDE: 'mvn clean package jboss-as:deploy' ?

                   

                  Stephen's suggestion to try a new clean copy of jboss-as-7.1.1.Final is a good one.

                  You might also want to clean out the old cached Maven repoisitory in your home .m2 directory to make sure you get the latest artifiacts.

                   

                  I have also contacted the owner of the quickstart to see if he has any other suggestions.

                  • 6. Re: failed to compile marshaller class
                    Jonathan Fuerth Master

                    Hi Meno,

                     

                    As Stephen and Sande said, this should definitely work as advertised when built using Maven on the command line. Can you try that and let us know?

                     

                    Once we know whether or not it works on the command line, we will know if we're dealing with a system-level incompatibility or an IntelliJ IDEA Maven integration incompatibility.

                    • 7. Re: failed to compile marshaller class
                      meno priezvisko Newbie

                      I gave it a rest for a day - now I've tried it a again and it works....

                      I did exactly the same as before and now it is OK...

                       

                      sorry for your trouble and thanks for trying to help me