1 2 3 4 Previous Next 47 Replies Latest reply on Oct 22, 2012 7:39 PM by Guillaume B Go to original post
      • 45. Re: weld-osgi Status?
        Guillaume B Newbie

        Moreover i can't active core-extension in jboss cause :

         

        16:22:00,073 ERROR [org.jboss.weld.osgi.weld-osgi-core-extension] (Thread-75) FrameworkEvent ERROR: org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unable to resolve HostBundleR

        evision[org.jboss.weld.osgi.weld-osgi-core-extension:1.2.0.SNAPSHOT]: missing requirement XPackageRequirement[atts={osgi.wiring.package=javax.inject, version=1.0.0},[org.jboss.weld.osgi.weld-osgi-core

        -extension:1.2.0.SNAPSHOT]]

        • 46. Re: weld-osgi Status?
          Tang Yong Newbie

          Ales Justin による書き込み:

           

          In addition, please see my email to you about Weld 1.2.0.Beta1's distribution problem.

          I have confirmed that in jboss repo, there are weld-osgi related bundles, however, in downloaded 1.2.0.Beta1 zip file,

          these bundles are missing.

          Yeah, seen that.

          I need to check, but you're welcome to check as well -- and provide a pull-request. :-)

          Hi Ales,

           

            I want to ask that what is the final distribution script?  core\jboss-as\jboss-as-7\pom.xml?

           

          Thanks!

          --Tang

          • 47. Re: weld-osgi Status?
            Guillaume B Newbie

            I've try to make the "ee" example work on latest jboss sources but i probably miss something because i can't do it ...

             

            Do i need to put something in jboss modules ? cause in the "ee" generated manifest it seems that

             

            deployment.org.jboss.weld.osgi.examples.weld-osgi-web-api:1.1.5 ...  is a dependancy and i can't find it

             

            Thanks

            1 2 3 4 Previous Next