4 Replies Latest reply on Jun 19, 2012 10:38 AM by aemdtuc

    Problem parsing tld file

    aemdtuc Newbie

      Hi!

       

      I'm new at the forum and this is my first time using JBoss.

       

      I'm trying to migrate a project from JBoss 4.2 to JBoss 7.1, and I get this error message:

       

      [code]

      5:27:09,637 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC00001: Failed to start service jboss.deployment.unit."Project.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."Project.war".PARSE: Failed to process phase PARSE of deployment "Project.war"

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_32]

          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_32]

          at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_32]

      Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS018014: Failed to parse XML descriptor "/D:/sw/jboss/jboss-as-7.1.1.Final/standalone/deployments/Project.war/WEB-INF/lib/taglibs-string.jar/META-INF/taglib.tld" at [713,18]

          at org.jboss.as.web.deployment.TldParsingDeploymentProcessor.parseTLD(TldParsingDeploymentProcessor.java:128)

          at org.jboss.as.web.deployment.TldParsingDeploymentProcessor.processTlds(TldParsingDeploymentProcessor.java:107)

          at org.jboss.as.web.deployment.TldParsingDeploymentProcessor.deploy(TldParsingDeploymentProcessor.java:83)

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

          ... 5 more

      [/code]

       

      I've found some people with problems like this, some of them could resolve it just changing at the tld file things like:
      <bodycontent>jsp</bodycontent> to <bodycontent>JSP</bodycontent>

       

      but I tried some of this and still have the same problem

       

      My problem is at this here: <bodycontent>EMPTY</bodycontent>

      I have to change to empty, but how do I do this if it's part of the jar and I can't change at all?!


      Thanks