No, operation names need to be unique in your service interface. Operation overloading is prohibited by WS-I Basic Profile as well:
Would it not be possible for the operation names to represented as "operationA" and "operationB" or perhaps "operation(A)" and "operation(B)" within the SwicthYard context?
The main reason we do this is for consistency across all interface types. Each of the interface types we support reduce down to the same generic metadata model which includes a list of operations keyed by operation name. While it's true that we could generate a unique name from a source interface like a Java class with overloaded methods, my gut tells me that this will lead to confusion down the road. Ideally, the operation name will clearly communicate the function of the service operation and operations which take different message types will clearly reflect that.