7 Replies Latest reply on Jun 20, 2014 8:00 AM by Meissa Sakho

    Sporadic Timeout waiting for module service: deployment.osgi.enterprise

    Rico Neubauer Novice

      JBoss 7.1.1

      Sporadically JBoss start-up fails with error below - loading osgi.enterprise fails. Result is that nothing else is done - no more deployments. Only a restart helps.

       

      Locally tested with a patched version, which increased the timeout value, but this does not help: timeout is always reached, only after a longer time. So the assumption is that there is a dead-lock or race-condition leading to the listener not getting notified.

       

      Is this a known bug (did not find anything in JIRA), or should I open-up one?

       

      org.jboss.msc.service.fail JB${bisas.pid} MSC service thread 1-16 ERROR MSC00001: Failed to start service jbosgi.AutoInstallProvider.COMPLETE: org.jboss.msc.service.StartException in service jbosgi.AutoInstallProvider.COMPLETE: Failed to start service
       at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
       at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.IllegalStateException: Cannot load module: deployment.osgi.enterprise:4.2.0.201003190513
       at org.jboss.osgi.framework.internal.ResolverPlugin.loadModules(ResolverPlugin.java:261)
       at org.jboss.osgi.framework.internal.ResolverPlugin.applyResolverResults(ResolverPlugin.java:229)
       at org.jboss.osgi.framework.internal.ResolverPlugin.resolveAll(ResolverPlugin.java:209)
       at org.jboss.osgi.framework.internal.PackageAdminPlugin.resolveBundles(PackageAdminPlugin.java:385)
       at org.jboss.as.osgi.service.AutoInstallIntegration$1.start(AutoInstallIntegration.java:176)
       at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
       at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
       ... 3 more
      Caused by: org.jboss.modules.ModuleLoadException: Timeout waiting for module service: deployment.osgi.enterprise:4.2.0.201003190513
       at org.jboss.as.server.moduleservice.ServiceModuleLoader$ModuleSpecLoadListener.getModuleSpec(ServiceModuleLoader.java:133)
       at org.jboss.as.server.moduleservice.ServiceModuleLoader.findModule(ServiceModuleLoader.java:174)
       at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275)
       at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222)
       at org.jboss.as.server.moduleservice.ServiceModuleLoader.preloadModule(ServiceModuleLoader.java:158)
       at org.jboss.modules.ModuleLoader.preloadExportedModule(ModuleLoader.java:233)
       at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:246)
       at org.jboss.as.osgi.service.ModuleLoaderIntegration.preloadModule(ModuleLoaderIntegration.java:191)
       at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:204)
       at org.jboss.osgi.framework.internal.ModuleManagerPlugin.loadModule(ModuleManagerPlugin.java:556)
       at org.jboss.osgi.framework.internal.ResolverPlugin.loadModules(ResolverPlugin.java:259)
       ... 9 more
      
        • 1. Re: Sporadic Timeout waiting for module service: deployment.osgi.enterprise
          Roman Chukh Newbie

          I can confirm this behavior. And it is also happens occasionally.

          Still, sometimes it fails to start another OSGI bundle(but "deployment.osgi.enterprise:4.2.0.201003190513" fails often as well):

           

          [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Failed to start service jbosgi.AutoInstallProvider.COMPLETE: org.jboss.msc.service.StartException in service jbosgi.AutoInstallProvider.COMPLETE: Failed to start service

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_31]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_31]

              at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]

          Caused by: java.lang.IllegalStateException: Cannot load module: deployment.jbosgi-http-api:1.0.5

              at org.jboss.osgi.framework.internal.ResolverPlugin.loadModules(ResolverPlugin.java:261)

              at org.jboss.osgi.framework.internal.ResolverPlugin.applyResolverResults(ResolverPlugin.java:229)

              at org.jboss.osgi.framework.internal.ResolverPlugin.resolveAll(ResolverPlugin.java:209)

              at org.jboss.osgi.framework.internal.PackageAdminPlugin.resolveBundles(PackageAdminPlugin.java:385)

              at org.jboss.as.osgi.service.AutoInstallIntegration$1.start(AutoInstallIntegration.java:176)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              ... 3 more

          Caused by: org.jboss.modules.ModuleLoadException: Timeout waiting for module service: deployment.jbosgi-http-api:1.0.5

              at org.jboss.as.server.moduleservice.ServiceModuleLoader$ModuleSpecLoadListener.getModuleSpec(ServiceModuleLoader.java:133) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.as.server.moduleservice.ServiceModuleLoader.findModule(ServiceModuleLoader.java:174) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.1.GA]

              at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.1.GA]

              at org.jboss.as.server.moduleservice.ServiceModuleLoader.preloadModule(ServiceModuleLoader.java:158) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.modules.ModuleLoader.preloadExportedModule(ModuleLoader.java:233) [jboss-modules.jar:1.1.1.GA]

              at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:246) [jboss-modules.jar:1.1.1.GA]

              at org.jboss.as.osgi.service.ModuleLoaderIntegration.preloadModule(ModuleLoaderIntegration.java:191)

              at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:204) [jboss-modules.jar:1.1.1.GA]

              at org.jboss.osgi.framework.internal.ModuleManagerPlugin.loadModule(ModuleManagerPlugin.java:556)

              at org.jboss.osgi.framework.internal.ResolverPlugin.loadModules(ResolverPlugin.java:259)

              ... 9 more

          It happens on windows(with 'full' profile), as well as on linux (with 'full-ha' profile). Yet I cannot reproduce this bug with identical settings on my machine.

          Worth noticing that it only happens with other bundles deployed. In example - following flow always help to solve this issue:

          1. Undeploy custom bundles

          2. Stop jboss

          3. Start jboss

          4. Deploy custom bundles

          • 2. Re: Sporadic Timeout waiting for module service: deployment.osgi.enterprise
            Alexander Koledzhikov Newbie

            The problem can be reproduced with 100% success rate by setting the number of deployment threads to 1. This can be achieved using the <option value="-Dorg.jboss.server.bootstrap.maxThreads=1"/> jvm property.

            I think the root of the problem is in org.jboss.as.server.moduleservice.ServiceModuleLoader and the asynchronous execution of listener tasks. The method findModule looks like this:

             

                ...

                    ModuleSpecLoadListener listener = new ModuleSpecLoadListener(identifier);

                    controller.addListener(listener);

                    return listener.getModuleSpec();

                ...

             

            And the successfull, not-timeouted completion of listener.getModuleSpec(); requires that the listener task added from here - controller.addListener(listener) - to be completed successfully. Unfortunately, this won't happen since there is only 1 deployer thread, which is currently busy. So, after 2 seconds, the ModuleTimeoutException is thrown.

            Of course, running 2 or more threads means that the problem will occur much less often, but still happens sometimes.

            Also, I've noted that it only appears with osgi bundles - haven't seen it with enterprise archives or jboss modules.

             

            1 of 1 people found this helpful
            • 4. Re: Sporadic Timeout waiting for module service: deployment.osgi.enterprise
              Thomas Diesler Master

              Alexander, you are a hero - thanks for looking into this. Your report may have saved many hours of investigation.

              1 of 1 people found this helpful
              • 5. Re: Sporadic Timeout waiting for module service: deployment.osgi.enterprise
                Sergiy Uvarov Newbie

                According to tasks in JIRA it has to be fixed but it is still reproduced on 7.2.0.Alpha1-SNAPSHOT build 1291.

                 

                I deploy my OSGi application packaged as EAR with about 50 bundles. It successfully deploys on my computer ( Intel(R) Core(TM) i5 ) but it always fails on a slower computer ( Intel(R) Core(TM)2 Duo ).

                I also tried to increase timeout in ServiceModuleLoader and it didn't help.

                 

                I was able to run my application on the slower computer only by increasing number of boot strap threads to 16 ( -Dorg.jboss.server.bootstrap.maxThreads=16 ).

                If I set this value to 1 on my faster computer it also fails to start.

                 

                Exception:

                 

                17:11:38,467 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.module.service."deployment.EMRApplication-1.0.0.ear.WorkbenchFeature-1.0.0.jar".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.WorkbenchFeature-1.0.0.jar".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.WorkbenchFeature-1.0.0.jar:main
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:92) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_37]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_37]
                        at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_37]
                Caused by: org.jboss.modules.ModuleNotFoundException: deployment.EMRApplication-1.0.0.ear:main
                        at org.jboss.modules.ModuleLoader$FutureModule.getModule(ModuleLoader.java:511) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:261) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ServiceModuleLoader.preloadModule(ServiceModuleLoader.java:158) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.modules.Module.addExportedPaths(Module.java:987) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.addPaths(Module.java:893) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.link(Module.java:1206) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.relinkIfNecessary(Module.java:1235) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        ... 5 more
                
                
                17:11:38,467 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC00001: Failed to start service jboss.module.service."deployment.EMRApplication-1.0.0.ear.EMRWeb-1.0.0.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.EMRWeb-1.0.0.war".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.EMRWeb-1.0.0.war:main
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:92) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_37]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_37]
                        at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_37]
                Caused by: org.jboss.modules.ModuleNotFoundException: deployment.EMRApplication-1.0.0.ear:main
                        at org.jboss.modules.ModuleLoader$FutureModule.getModule(ModuleLoader.java:511) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:261) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ServiceModuleLoader.preloadModule(ServiceModuleLoader.java:158) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.modules.Module.addPaths(Module.java:851) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.link(Module.java:1206) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.relinkIfNecessary(Module.java:1235) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        ... 5 more
                
                
                17:11:38,467 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.module.service."deployment.EMRApplication-1.0.0.ear.CommonModel-1.0.0.jar".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.CommonModel-1.0.0.jar".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.CommonModel-1.0.0.jar:main
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:92) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_37]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_37]
                        at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_37]
                Caused by: org.jboss.modules.ModuleNotFoundException: deployment.EMRApplication-1.0.0.ear:main
                        at org.jboss.modules.ModuleLoader$FutureModule.getModule(ModuleLoader.java:511) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:261) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ServiceModuleLoader.preloadModule(ServiceModuleLoader.java:158) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.modules.Module.addExportedPaths(Module.java:987) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.addPaths(Module.java:893) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.link(Module.java:1206) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.relinkIfNecessary(Module.java:1235) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        ... 5 more
                
                
                17:11:38,477 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Failed to start service jboss.module.service."deployment.EMRApplication-1.0.0.ear.HealthCareModel-1.0.0.jar".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.HealthCareModel-1.0.0.jar".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.HealthCareModel-1.0.0.jar:main
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:92) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_37]
                        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_37]
                        at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_37]
                Caused by: org.jboss.modules.ModuleLoadException: JBAS018760: Timeout waiting for module service: deployment.EMRApplication-1.0.0.ear:main
                        at org.jboss.as.server.moduleservice.ServiceModuleLoader$ModuleSpecLoadListener.getModuleSpec(ServiceModuleLoader.java:133) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.as.server.moduleservice.ServiceModuleLoader.findModule(ServiceModuleLoader.java:174) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ServiceModuleLoader.preloadModule(ServiceModuleLoader.java:158) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        at org.jboss.modules.Module.addExportedPaths(Module.java:987) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.addPaths(Module.java:893) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.link(Module.java:1206) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.Module.relinkIfNecessary(Module.java:1235) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.3.GA]
                        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT]
                        ... 5 more
                
                
                17:11:38,655 INFO  [org.jboss.as.osgi] (MSC service thread 1-1) JBAS011911: Bound system context: java:jboss/osgi/BundleContext
                17:11:38,938 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 20) JBAS018559: Deployed "EMRApplication-1.0.0.ear"
                17:11:38,941 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
                JBAS014777:   Services which failed to start:      service jboss.module.service."deployment.EMRApplication-1.0.0.ear.CommonModel-1.0.0.jar".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.CommonModel-1.0.0.jar".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.CommonModel-1.0.0.jar:main
                      service jboss.module.service."deployment.EMRApplication-1.0.0.ear.WorkbenchFeature-1.0.0.jar".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.WorkbenchFeature-1.0.0.jar".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.WorkbenchFeature-1.0.0.jar:main
                      service jboss.module.service."deployment.EMRApplication-1.0.0.ear.EMRWeb-1.0.0.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.EMRWeb-1.0.0.war".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.EMRWeb-1.0.0.war:main
                      service jboss.module.service."deployment.EMRApplication-1.0.0.ear.HealthCareModel-1.0.0.jar".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.EMRApplication-1.0.0.ear.HealthCareModel-1.0.0.jar".main: JBAS018759: Failed to load module: deployment.EMRApplication-1.0.0.ear.HealthCareModel-1.0.0.jar:main
                
                
                • 7. Re: Sporadic Timeout waiting for module service: deployment.osgi.enterprise
                  Meissa Sakho Newbie

                  Hi Thomas,

                  As I understand, the workaround of this issue is to increase -Dorg.jboss.server.bootstrap.maxThreads at jboss start time.

                  And the issue is fixed from the EAP 6.1.0.Alpha (7.2.0.Final) version.

                   

                  Can you confirm my understanding?

                  thankx in advance.

                  Massai