1 Reply Latest reply on Jun 21, 2012 8:29 AM by Jesper Pedersen

    Porting -ra.xml from JBoss 5 to JBoss 7.1.1 Final

    Sergiu Pienar Expert

      Hi,

       

      My -ra.xml looks like this :

       

      <?xml version="1.0" encoding="UTF-8"?>

      <connector xmlns="http://java.sun.com/xml/ns/j2ee"

              xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

              xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee

                      http://java.sun.com/xml/ns/j2ee/connector_1_5.xsd"

              version="1.5">

       

       

          <display-name>MyResourceAdapter</display-name>

          <vendor-name>me</vendor-name>

          <eis-type>Connector System</eis-type>

          <resourceadapter-version>0.1.0</resourceadapter-version>

          <resourceadapter>

              <resourceadapter-class>org.jboss.resource.deployment.DummyResourceAdapter</resourceadapter-class>

              <outbound-resourceadapter>

                  <connection-definition>

                      <managedconnectionfactory-class>com.ManagedConnectionFactory</managedconnectionfactory-class>

                      <connectionfactory-interface>com.ConnectionFactory</connectionfactory-interface>

                      <connectionfactory-impl-class>com.ConnectionFactoryImpl</connectionfactory-impl-class>

                      <connection-interface>comConnection</connection-interface>

                      <connection-impl-class>com.ConnectionImpl</connection-impl-class>

                  </connection-definition>

                  <transaction-support>XATransaction</transaction-support>

                  <reauthentication-support>false</reauthentication-support>

              </outbound-resourceadapter>

          </resourceadapter>

      </connector>

       

      How can I make this compatible with JBoss 7.1.1 ?