6 Replies Latest reply on Feb 23, 2017 3:22 PM by Rasool Mohammad

    New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver_jdbc (missing) dependents

    Hari Kishore Yecharla Newbie

      I have placed jtds-1.2.5.jar file and configured in the module.xml in module/......./main folder. You can see the standalone.xml file also. But still I getting the same error. Please help me to sortout this problem.

        • 1. Re: New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver_jdbc (missing) dependents
          Stephen Coy Master

          You need to make up your mind which JDBC driver you're using.

           

          Let's assume you want to use the jtds driver rather the microsoft driver.

           

          You need to:

          • change "mssqlserver.jar" to "jtds-1.2.5.jar" in the module.xml file and ensure that the jtds-1.2.5.jar jar file is installed adjacent to the module.xml file.
          • uncomment <driver-class>net.sourceforge.jtds.jdbc.Driver</driver-class> in the standalone.xml and delete <driver-class>com.microsoft.jdbc.sqlserver.SQLServerDriver</driver-class>.
          • 2. Re: New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver_jdbc (missing) dependents
            Rajendra J Newbie

            Hi Guys,

             

              I have same problem New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver (missing) dependents

             

              Am using the same configuration as mentioned above, please provide me the steps to configure ms sql data source in JBoss AS 7

             

            Here am providing my configuration steps :

             

            1. JBoss AS 7 Home \ modules \ net \ sourceforge \ jtds \ main

             

               I have added the module.xml which contains following configuration

             

            <?xml version="1.0" encoding="UTF-8"?>

            <module xmlns="urn:jboss:module:1.0" name="net.sourceforge.jtds">

              <resources>

                <resource-root path="jtds12.jar"/>

                <resource-root path="jtds-src.jar"/>

              </resources>

              <dependencies>

                <module name="javax.api"/>

                <module name="javax.transaction.api"/>

              </dependencies>

            </module>

             

            2. JBoss AS 7 Home \ modules \ net \ sourceforge \ jtds \ main

             

               I have added the following jars

               

                   1. jtds12.jar

                   2. jtds-src.jar

             

             

            3. JBoss AS 7 Home \  Standalone \ configuration \ standalone.xml

               I have added the following configuration :
             

            <datasources>

                    <datasource jndi-name="java:jboss/datasources/MSSqlDS" pool-name="MSSqlDS" enabled="true" use-java-context="true">

                                <connection-url>jdbc:jtds:sqlserver://IPAddress:1433/DBName</connection-url>

                                <driver>sqlserver</driver>

                                <transaction-isolation>TRANSACTION_READ_COMMITTED</transaction-isolation>

                                <pool>

                                    <min-pool-size>10</min-pool-size>

                                    <max-pool-size>100</max-pool-size>

                                    <prefill>true</prefill>

                                    <use-strict-min>false</use-strict-min>

                                    <flush-strategy>FailingConnectionOnly</flush-strategy>

                                </pool>

                                <security>

                                    <user-name>XXXXX</user-name>

                                    <password>XXXXXXXXXXX</password>

                                </security>                  

                            </datasource>

                         <drivers>

                        <driver name="sqlserver" module="net.sourceforge.jtds">

                              <driver-class>net.sourceforge.jtds.jdbc.Driver</driver-class>

                                </driver>

                            </drivers>

                        </datasources>

               

            • 4. Re: New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver_jdbc (missing) dependents
              Rajendra J Newbie

              Hi Hari,

               

                  I placed the first jar i.e,   1. jtds12.jar and  I configured the same in module.xml then also same problem.

               

                 New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver  (missing) dependents.

               

                am bit worrying about this conf.  why its not working.

               

              Can you place your working configuration here?

               

               

              Thanks in advance

                Rajendra J

              • 5. Re: New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver_jdbc (missing) dependents
                Rajendra J Newbie

                Hi guys,

                 

                   Sorry, I have made  a mistake in placing the drivers in folder ( wrongly typed folder name  Instead of jtds i made as jstd ).  Just i checked in the morning.. Now its working fine.. Thank u Hari for respoding...

                 

                   The above configuration works fine..

                 

                   Thanks all who are supporting...

                • 6. Re: New missing/unsatisfied dependencies: service jboss.jdbc-driver.sqlserver_jdbc (missing) dependents
                  Rasool Mohammad Newbie

                  Hi,

                  first stop the WildFly server.

                  then update standalone.xml file to add MS-SQL JTDS driver details and Datasource details like below:

                   

                   

                  <subsystem xmlns="urn:jboss:domain:datasources:4.0">

                  <datasources>

                                  <datasource jta="true" jndi-name="java:/jdbc/speedtest-datasource" pool-name="MSSQLDSspeedTestDEV" enabled="true" use-ccm="true">

                  <connection-url>jdbc:jtds:sqlserver://serverName:1433;DatabaseName=myDB</connection-url>

                                      <driver-class>net.sourceforge.jtds.jdbc.Driver</driver-class>

                  <driver>JTDS</driver>

                                      <security>

                  <user-name>myUsername</user-name>

                  <password>myPassword</password>

                                      </security>

                                      <validation>

                  <valid-connection-checker class-name="org.jboss.jca.adapters.jdbc.extensions.mssql.MSSQLValidConnectionChecker"/>

                  <background-validation>true</background-validation>

                                      </validation>

                                  </datasource>

                                  <drivers>

                                      <driver name="JTDS" module="net.sourceforge">

                  <driver-class>net.sourceforge.jtds.jdbc.Driver</driver-class>

                                      </driver>                 

                                  </drivers>

                  </datasources>

                  </subsystem>

                   

                   

                  Module.xml for MS SQL JTDS: path :  E:\Softwares\wildfly-10.1.0.Final\wildfly-10.1.0.Final\modules\system\layers\base\net\sourceforge\main  ( need to create directory structure as highlighted and add module.xml and jtds-1.3.0.jar files)

                  (note in this example i have used module name as "net.sourceforge" and created the folder structure path as "net\sourceforge\main"). Please note this is more important to match the directory path and module name in module,xml file

                   

                   

                  <?xml version="1.0" encoding="UTF-8"?>

                  <module xmlns="urn:jboss:module:1.0" name="net.sourceforge">

                  <resources>

                  <resource-root path="jtds-1.3.0.jar"/>

                  </resources>

                  <dependencies>

                  <module name="javax.api"/>

                  <module name="javax.transaction.api"/>

                  </dependencies>

                  </module>

                   

                  Note: Please note that the path highlighted in green above at 2 places should match (ie directory structure and module name in module.xml),

                   

                  For example. If  you have created directory structure as E:\Softwares\wildfly-10.1.0.Final\wildfly-10.1.0.Final\modules\system\layers\base\net\sourceforge\jtds\main  then module name in module.xml file should be “net.sourceforge.jtds” as shown below in module.xml file

                   

                  1. Module.xml:

                  <?xml version="1.0" encoding="UTF-8"?>

                  <module xmlns="urn:jboss:module:1.0" name="net.sourceforge.jtds">

                  <resources>

                  <resource-root path="jtds-1.3.0.jar"/>

                  </resources>

                  <dependencies>

                  <module name="javax.api"/>

                  <module name="javax.transaction.api"/>

                  </dependencies>

                  </module>

                   

                   

                  now save these two files and restart the wildFLY server.

                   

                   

                  Regards,

                  Rasool Javeed Mohammad

                  javeed.mca@gmail.com

                  1 of 1 people found this helpful