6 Replies Latest reply on Jul 25, 2012 5:12 AM by Marcus Noerder-Tuitje

    WARN  [org.hornetq.core.cluster.impl.DiscoveryGroupImpl] (hornetq-discovery-group-thread-dg-group1) There are more than one servers on the network broadcasting the same node id.

    Marcus Noerder-Tuitje Newbie

      Hello,

       

      I face the message

       

      2012-07-04 12:23:37,769 WARN  [org.hornetq.core.cluster.impl.DiscoveryGroupImpl] (hornetq-discovery-group-thread-dg-group1) There are more than one servers on the network broadcasting the same node id. You will see this message exactly once (per node) if a node is restarted, in which case it can be safely ignored. But if it is logged continuously it means you really do have more than one node on the same network active concurrently with the same node id. This could occur if you have a backup node active at the same time as its live node.

       

      periodically in my server log. I run jboss 6.0 with a Gossip Router (windows HyperV Infrastructure with Linux VM does not do the trick ).

       

      Although I define the node-Id in my start script plus the cluster group Id etc I am facing this message. Is there a known bug in jboss 6.0.0 Final ? Or does HornetQ do UDP Multicasting itself - from the Jboss point of view I know this is a problem in a windows world)?

       

      I mounted a shared device, and both servers use it to define the queues etc., so I can see the behaviour of the queues as described. I also switched to NIO because it is a CIFS mountpoint, but with no success.

       

      What am I doing wrong?

       

      Thanks in advance,

      marcus

       

      PS: from the jgroups config I run the TCP stack,  which I attached as a standalone fragment