0 Replies Latest reply on Jul 12, 2012 7:56 PM by Siddharth Sehgal

    JBoss AS 7 not reading/loading JSP Files

    Siddharth Sehgal Newbie

      I am using Eclipse Jee Juno (32 bit for windows). I downloaded and installed JBoss tools & AS 7 from JBoss website. Everything is installed correctly to my knowledge and is running fine but when I am trying to run JSP files on server, It starts throwing errors. For just writing  "Hello" in the JSP file and running it on server

       

      the error shown is.

       

       

      An internal error occurred during: "Launching client".

      java.lang.NullPointerException

       

      Console shows following details

       

       

      19:29:49,359 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found First.war in deployment directory. To trigger deployment create a file called First.war.dodeploy

      19:29:49,593 INFO [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on /127.0.0.1:9999

      19:29:49,687 INFO [org.jboss.as.remoting] (MSC service thread 1-2) JBAS017100: Listening on localhost/127.0.0.1:4447

      19:29:50,155 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-2) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]

      19:29:50,187 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014777: Services which failed to start: service jboss.web.connector.http:

      in service jboss.web.connector.http: JBAS018007: Error starting web connector

       

       

      I tried to run an a sample project in JBoss tools HTML 5 named poh5

       

      it gave following error

       

      An internal error occurred during: "Building JPA Projects".

      org/eclipse/jpt/jpa/core/JpaAnnotationProvider

       

      Console shows following details for this project

       

       

      19:29:49,156 INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-1) JBAS015012: Started FileSystemDeploymentService for directory E:\EclipseEE\server\jboss-as-7.1.1.Final\jboss-as-7.1.1.Final\standalone\deployments

      19:29:49,343 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Failed to start service jboss.web.connector.http:

      org.jboss.msc.service.StartException

      in service jboss.web.connector.http: JBAS018007: Error starting web connector

       

       

       

       

       

       

       

       

       

       

       

      It seems to be some problem with Web Connector. Any suggestions what might be wrong here?? Thanks

       

      Sid