2 Replies Latest reply on Jul 9, 2008 3:08 AM by Ales Justin

    Classloading question

    Chip Schoch Novice

      I downloaded AS5 and when I tried to deploy my webapp ear file I get a warning about :

      2008-07-08 16:31:37,662 WARN [org.jboss.system.deployers.HackClassloaderMetaDataDeployer] FIXME Using loader repository config: com.eLynx:loader=USignWebapp for vfszip:/C:/JBoss5/jboss-5.0.0.CR1/server/expedite/deploy/messaging/USignWebapp.ear use classloading metadata not loader repository config


      And in my servlet initialization this line no longer returns a stream

      InputStream is = getResourceAsStream ("WEB-INF/command.xml");


      What can I change to remedy this?

        • 1. Re: Classloading question
          Andrew Rubinger Master

           

          "chip_schoch" wrote:
          I downloaded AS5 and when I tried to deploy my webapp ear file I get a warning


          This you can ignore. :)

          "chip_schoch" wrote:
          And in my servlet initialization this line no longer returns a stream

          InputStream is = getResourceAsStream ("WEB-INF/command.xml");


          What can I change to remedy this?


          Perhaps the Thread Context CL for the Servlet init is not the same one that loaded your webapp classes; try:

          this.getClass().getClassLoader().getResourceAsStream("resource")


          ..from within your Servlet (assuming the servlet is packaged alongside the resource you're trying to load).

          S,
          ALR

          • 2. Re: Classloading question
            Ales Justin Master

             

            "chip_schoch" wrote:
            I downloaded AS5 and when I tried to deploy my webapp ear file I get a warning about :

            2008-07-08 16:31:37,662 WARN [org.jboss.system.deployers.HackClassloaderMetaDataDeployer] FIXME Using loader repository config: com.eLynx:loader=USignWebapp for vfszip:/C:/JBoss5/jboss-5.0.0.CR1/server/expedite/deploy/messaging/USignWebapp.ear use classloading metadata not loader repository config


            This one suggest you drop the old classloading info notion, and use the new jboss-classloading.xml for this kind of info.
            See http://www.jboss.com/index.html?module=bb&op=viewtopic&t=130122

            "chip_schoch" wrote:

            And in my servlet initialization this line no longer returns a stream

            InputStream is = getResourceAsStream ("WEB-INF/command.xml");


            What can I change to remedy this?

            What about if you put '/' infront WEB-INF?