2 Replies Latest reply on Jul 30, 2012 4:22 PM by Tom Cunningham

    'Broken window' alert-- Ivy can't find jms.jar

    Rick Wagner Newbie

      Hello,

       

      I've just tried a source build, it seems Ivy can't find jms.jar:

       

        [java] [ivy:retrieve]
      [NOT FOUND  ] javax.jms#jms;1.1!jms.jar (439ms)
           [java] [ivy:retrieve]==== ibiblio: tried
           [java] [ivy:retrieve]  http://repo1.maven.org/maven2/javax/jms/jms/1.1/jms-1.1.jar

       

      I looked on the maven repo, sure enough it isn't there.

       

      I'll go fetch the .jar and carry on, but wanted to let the community know about the busted script.

       

      Thanks,

       

      Rick

        • 1. Re: 'Broken window' alert-- Ivy can't find jms.jar
          Tom Cunningham Master

          I have a working fix below, but I need to research why exactly it's not picking up the JAR from the entry it has for JBoss Nexus.     What's there now seems like it should work.    The JAR is obviously there, and when I specify it, it finds it.

           

          I'll have fixes checked in to current branches on Monday, if anyone needs it in the meantime, here's a patch.

           

          Index: rosetta/deployer-as6/ivysettings.xml

          ===================================================================

          --- rosetta/deployer-as6/ivysettings.xml          (revision 38153)

          +++ rosetta/deployer-as6/ivysettings.xml          (working copy)

          @@ -11,7 +11,13 @@

                       </url>

                       <ibiblio name="ibiblio" m2compatible="true"/>

                   </chain>

          +

          +        <url name="jms" m2compatible="true">

          +      <artifact pattern="https://repository.jboss.org/nexus/content/groups/public/[organisation]/[artifact]/[revision]/[artifact]-[revision].[ext]"/>

          +         </url>

          +

               </resolvers>

               <modules>

          +        <module organisation="javax.jms" name="*" resolver="jms"/>

               </modules>

          </ivysettings>

          • 2. Re: 'Broken window' alert-- Ivy can't find jms.jar
            Tom Cunningham Master

            Just to close this out - the fix has been applied to trunk and JBESB_4_11_CP, and will be applied to other branches as necessary.