3 Replies Latest reply on Jul 31, 2012 8:17 AM by michajil_tigrow

    AcitveMq integration problem - port 61616 gets closed

    michajil_tigrow Newbie

      Hi

      I'm porting some apps from Jboss 4.2.3 to 7.1.1 Final. I need to add activemq to jboss.

      I've read couple of articles about this here on forum and they seem to be very helpful (i do get info that activemq is deployed) but I didnt found anything about port 61616 not being open.

      Just after starting up the server I get the info from server that port 61616 is being closed and after that ActiveMq error that it cannot connect to this port

       

      09:09:50,025 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018

      559: Deployed "activemq-ra.rar"

      09:09:57,343 DEBUG [org.apache.activemq.transport.tcp.TcpTransport] (default-sho

      rt-running-threads-threads - 2) Stopping transport tcp://localhost:61616

      09:09:57,350 DEBUG [org.apache.activemq.ra.ActiveMQEndpointWorker] (default-shor

      t-running-threads-threads - 2) Failed to connect: Could not connect to broker UR

      L: tcp://localhost:61616. Reason: java.net.ConnectException: Connection refused:

      connect: javax.jms.JMSException: Could not connect to broker URL: tcp://localho

      st:61616. Reason: java.net.ConnectException: Connection refused: connect

              at org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSuppo

      rt.java:35) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnectio

      n(ActiveMQConnectionFactory.java:295) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSH

      OT]

              at org.apache.activemq.ActiveMQConnectionFactory.createConnection(Active

      MQConnectionFactory.java:192) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.ra.ActiveMQResourceAdapter.makeConnection(ActiveM

      QResourceAdapter.java:133) [activemq-ra-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.ra.ActiveMQEndpointWorker$1.run(ActiveMQEndpointW

      orker.java:106) [activemq-ra-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.jboss.jca.core.workmanager.WorkWrapper.run(WorkWrapper.java:212)

      [ironjacamar-core-impl-1.0.9.Final.jar:1.0.9.Final]

              at org.jboss.threads.SimpleDirectExecutor.execute(SimpleDirectExecutor.j

      ava:33)

              at org.jboss.threads.QueueExecutor.runTask(QueueExecutor.java:801)

              at org.jboss.threads.QueueExecutor.access$100(QueueExecutor.java:45)

              at org.jboss.threads.QueueExecutor$Worker.run(QueueExecutor.java:821)

              at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_30]

              at org.jboss.threads.JBossThread.run(JBossThread.java:122)

      Caused by: java.net.ConnectException: Connection refused: connect

              at java.net.PlainSocketImpl.socketConnect(Native Method) [rt.jar:1.6.0_3

      0]

              at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351) [rt.jar:

      1.6.0_30]

              at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213) [

      rt.jar:1.6.0_30]

              at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200) [rt.jar:1.

      6.0_30]

              at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366) [rt.jar:1.

      6.0_30]

              at java.net.Socket.connect(Socket.java:529) [rt.jar:1.6.0_30]

              at org.apache.activemq.transport.tcp.TcpTransport.connect(TcpTransport.j

      ava:504) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.transport.tcp.TcpTransport.doStart(TcpTransport.j

      ava:467) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.util.ServiceSupport.start(ServiceSupport.java:54)

      [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.transport.AbstractInactivityMonitor.start(Abstrac

      tInactivityMonitor.java:121) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.transport.TransportFilter.start(TransportFilter.j

      ava:58) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.transport.WireFormatNegotiator.start(WireFormatNe

      gotiator.java:72) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.transport.TransportFilter.start(TransportFilter.j

      ava:58) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.transport.TransportFilter.start(TransportFilter.j

      ava:58) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSHOT]

              at org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnectio

      n(ActiveMQConnectionFactory.java:275) [activemq-core-5.6-SNAPSHOT.jar:5.6-SNAPSH

      OT]

              ... 10 more

       

      Can anybody suggest what's wrong? I'm not using the ironjacamar.xml mentioned in other threads. My version of activemq-ra is 5.6

       

      My ra.xml

      {code:xml}

      <?xml version="1.0" encoding="UTF-8"?>

      <!-- Licensed to the Apache Software Foundation (ASF) under one or more contributor

          license agreements. See the NOTICE file distributed with this work for additional

          information regarding copyright ownership. The ASF licenses this file to

          You under the Apache License, Version 2.0 (the "License"); you may not use

          this file except in compliance with the License. You may obtain a copy of

          the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required

          by applicable law or agreed to in writing, software distributed under the

          License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS

          OF ANY KIND, either express or implied. See the License for the specific

          language governing permissions and limitations under the License. -->

       

      <connector xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

          xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee

          http://java.sun.com/xml/ns/j2ee/connector_1_5.xsd"

          version="1.5">

          <description>ActiveMQ  inbound and outbound JMS ResourceAdapter</description>

          <display-name>ActiveMQ JMS Resource Adapter</display-name>

          <vendor-name>activemq.org</vendor-name>

          <eis-type>JMS 1.1</eis-type>

          <resourceadapter-version>1.0</resourceadapter-version>

          <resourceadapter>

              <resourceadapter-class>org.apache.activemq.ra.ActiveMQResourceAdapter</resourceadapter-class>

              <config-property>

                  <description>

                    The URL to the ActiveMQ server that you want this connection to connect to.  If using

                    an embedded broker, this value should be 'vm://jboss-activemq-broker'.

                  </description>

                  <config-property-name>ServerUrl</config-property-name>

                  <config-property-type>java.lang.String</config-property-type>

                  <config-property-value>tcp://localhost:61616</config-property-value>

              </config-property>

              <config-property>

                  <description>The default user name that will be used to establish connections to the ActiveMQ server.</description>

                  <config-property-name>UserName</config-property-name>

                  <config-property-type>java.lang.String</config-property-type>

                  <config-property-value>sa</config-property-value>

              </config-property>

              <config-property>

                  <description>The default password that will be used to log the default user into the ActiveMQ server.</description>

                  <config-property-name>Password</config-property-name>

                  <config-property-type>java.lang.String</config-property-type>

                  <config-property-value>undefined</config-property-value>

              </config-property>

              <config-property>

                  <description>The client id that will be set on the connection that is established to the ActiveMQ server.</description>

                  <config-property-name>Clientid</config-property-name>

                  <config-property-type>java.lang.String</config-property-type>

              </config-property>

              <config-property>

                  <description>Boolean to configure if outbound connections should reuse the inbound connection's session for sending messages.</description>

                  <config-property-name>UseInboundSession</config-property-name>

                  <config-property-type>java.lang.Boolean</config-property-type>

                  <config-property-value>false</config-property-value>

              </config-property>

       

       

              <outbound-resourceadapter>

                  <connection-definition>

                      <managedconnectionfactory-class>org.apache.activemq.ra.ActiveMQManagedConnectionFactory</managedconnectionfactory-class>

                      <connectionfactory-interface>javax.jms.ConnectionFactory</connectionfactory-interface>

                      <connectionfactory-impl-class>org.apache.activemq.ra.ActiveMQConnectionFactory</connectionfactory-impl-class>

                      <connection-interface>javax.jms.Connection</connection-interface>

                      <connection-impl-class>org.apache.activemq.ra.ManagedConnectionProxy</connection-impl-class>

                  </connection-definition>

                  <transaction-support>NoTransaction</transaction-support>

                  <reauthentication-support>false</reauthentication-support>

              </outbound-resourceadapter>

              <inbound-resourceadapter>

                  <messageadapter>

                      <messagelistener>

                          <messagelistener-type>javax.jms.MessageListener</messagelistener-type>

                          <activationspec>

                              <activationspec-class>org.apache.activemq.ra.ActiveMQActivationSpec</activationspec-class>

                              <required-config-property>

                                  <config-property-name>destination</config-property-name>

                              </required-config-property>

                              <required-config-property>

                                  <config-property-name>destinationType</config-property-name>

                              </required-config-property>

                          </activationspec>

                      </messagelistener>

                  </messageadapter>

              </inbound-resourceadapter>

              <adminobject>

                  <adminobject-interface>javax.jms.Queue</adminobject-interface>

                  <adminobject-class>org.apache.activemq.command.ActiveMQQueue</adminobject-class>

                  <config-property>

                      <config-property-name>PhysicalName</config-property-name>

                      <config-property-type>java.lang.String</config-property-type>

                  </config-property>

              </adminobject>

              <adminobject>

                  <adminobject-interface>javax.jms.Topic</adminobject-interface>

                  <adminobject-class>org.apache.activemq.command.ActiveMQTopic</adminobject-class>

                  <config-property>

                      <config-property-name>PhysicalName</config-property-name>

                      <config-property-type>java.lang.String</config-property-type>

                  </config-property>

              </adminobject>

          </resourceadapter>

      </connector>

      {code}

       

      My standalone.xml

      {code:xml}

      <?xml version='1.0' encoding='UTF-8'?>

       

      <server xmlns="urn:jboss:domain:1.2">

       

          <extensions>

              <extension module="org.jboss.as.clustering.infinispan"/>

              <extension module="org.jboss.as.configadmin"/>

              <extension module="org.jboss.as.connector"/>

              <extension module="org.jboss.as.deployment-scanner"/>

              <extension module="org.jboss.as.ee"/>

              <extension module="org.jboss.as.ejb3"/>

              <extension module="org.jboss.as.jaxrs"/>

              <extension module="org.jboss.as.jdr"/>

              <extension module="org.jboss.as.jmx"/>

              <extension module="org.jboss.as.jpa"/>

              <extension module="org.jboss.as.logging"/>

              <extension module="org.jboss.as.mail"/>

              <extension module="org.jboss.as.naming"/>

              <extension module="org.jboss.as.osgi"/>

              <extension module="org.jboss.as.pojo"/>

              <extension module="org.jboss.as.remoting"/>

              <extension module="org.jboss.as.sar"/>

              <extension module="org.jboss.as.security"/>

              <extension module="org.jboss.as.threads"/>

              <extension module="org.jboss.as.transactions"/>

              <extension module="org.jboss.as.web"/>

              <extension module="org.jboss.as.webservices"/>

              <extension module="org.jboss.as.weld"/>

          </extensions>

       

       

          <management>

              <security-realms>

                  <security-realm name="ManagementRealm">

                      <authentication>

                          <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                  </security-realm>

                  <security-realm name="ApplicationRealm">

                      <authentication>

                          <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                  </security-realm>

              </security-realms>

              <management-interfaces>

                  <native-interface security-realm="ManagementRealm">

                      <socket-binding native="management-native"/>

                  </native-interface>

                  <http-interface security-realm="ManagementRealm">

                      <socket-binding http="management-http"/>

                  </http-interface>

              </management-interfaces>

          </management>

       

          <profile>

              <subsystem xmlns="urn:jboss:domain:logging:1.1">

                  <console-handler name="CONSOLE">

                      <level name="DEBUG"/>

                      <formatter>

                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                      </formatter>

                  </console-handler>

                  <periodic-rotating-file-handler name="FILE">

                      <formatter>

                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                      </formatter>

                      <file relative-to="jboss.server.log.dir" path="server.log"/>

                      <suffix value=".yyyy-MM-dd"/>

                      <append value="true"/>

                  </periodic-rotating-file-handler>

                  <logger category="com.arjuna">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="org.apache.tomcat.util.modeler">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="sun.rmi">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="jacorb">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="jacorb.config">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="com.gemalto">

                      <level name="DEBUG"/>

                  </logger>

                  <root-logger>

                      <level name="DEBUG"/>

                      <handlers>

                          <handler name="CONSOLE"/>

                          <handler name="FILE"/>

                      </handlers>

                  </root-logger>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:configadmin:1.0"/>

              <subsystem xmlns="urn:jboss:domain:datasources:1.0">

                     ....

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">

                  <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" deployment-timeout="3000"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:ee:1.0">

                  <ear-subdeployments-isolated>false</ear-subdeployments-isolated>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:ejb3:1.2">

                  <session-bean>

                      <stateless>

                          <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>

                      </stateless>

                      <stateful default-access-timeout="5000" cache-ref="simple"/>

                      <singleton default-access-timeout="5000"/>

                  </session-bean>

                  <mdb>

                      <resource-adapter-ref resource-adapter-name="activemq-ra.rar"/>

                      <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>

                  </mdb>

                  <pools>

                      <bean-instance-pools>

                          <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                          <strict-max-pool name="mdb-strict-max-pool" max-pool-size="750" instance-acquisition-timeout="12" instance-acquisition-timeout-unit="MINUTES"/>

                      </bean-instance-pools>

                  </pools>

                  <caches>

                      <cache name="simple" aliases="NoPassivationCache"/>

                      <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>

                  </caches>

                  <passivation-stores>

                      <file-passivation-store name="file"/>

                  </passivation-stores>

                  <async thread-pool-name="default"/>

                  <timer-service thread-pool-name="default">

                      <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>

                  </timer-service>

                  <remote connector-ref="remoting-connector" thread-pool-name="default"/>

                  <thread-pools>

                      <thread-pool name="default">

                          <max-threads count="10"/>

                          <keepalive-time time="100" unit="milliseconds"/>

                      </thread-pool>

                  </thread-pools>

                  <iiop enable-by-default="false" use-qualified-name="false"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:infinispan:1.2" default-cache-container="hibernate">

                  <cache-container name="hibernate" default-cache="local-query">

                      <local-cache name="entity">

                          <transaction mode="NON_XA"/>

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </local-cache>

                      <local-cache name="local-query">

                          <transaction mode="NONE"/>

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </local-cache>

                      <local-cache name="timestamps">

                          <transaction mode="NONE"/>

                          <eviction strategy="NONE"/>

                      </local-cache>

                  </cache-container>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>

              <subsystem xmlns="urn:jboss:domain:jca:1.1">

                  <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>

                  <bean-validation enabled="true"/>

                  <default-workmanager>

                      <short-running-threads>

                          <core-threads count="50"/>

                          <queue-length count="50"/>

                          <max-threads count="50"/>

                          <keepalive-time time="10" unit="seconds"/>

                      </short-running-threads>

                      <long-running-threads>

                          <core-threads count="50"/>

                          <queue-length count="50"/>

                          <max-threads count="50"/>

                          <keepalive-time time="10" unit="seconds"/>

                      </long-running-threads>

                  </default-workmanager>

                  <cached-connection-manager/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>

              <subsystem xmlns="urn:jboss:domain:jmx:1.1">

                  <show-model value="true"/>

                  <remoting-connector/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jpa:1.0">

                  <jpa default-datasource=""/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:mail:1.0">

                  <mail-session jndi-name="java:jboss/mail/Default">

                      <smtp-server outbound-socket-binding-ref="mail-smtp"/>

                  </mail-session>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:naming:1.1"/>

              <subsystem xmlns="urn:jboss:domain:osgi:1.2" activation="lazy">

                  <properties>

                      <property name="org.osgi.framework.startlevel.beginning">

                          1

                      </property>

                  </properties>

                  <capabilities>

                      <capability name="javax.servlet.api:v25"/>

                      <capability name="javax.transaction.api"/>

                      <capability name="org.apache.felix.log" startlevel="1"/>

                      <capability name="org.jboss.osgi.logging" startlevel="1"/>

                      <capability name="org.apache.felix.configadmin" startlevel="1"/>

                      <capability name="org.jboss.as.osgi.configadmin" startlevel="1"/>

                  </capabilities>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>

              <subsystem xmlns="urn:jboss:domain:remoting:1.1">

                  <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:resource-adapters:1.0">

                   <resource-adapters>

                      <resource-adapter>

                          <archive>

                              activemq-ra.rar

                          </archive>

                          <transaction-support>XATransaction</transaction-support>

                          <config-property name="ServerUrl">

                              tcp://localhost:61616

                          </config-property>

                          <config-property name="BrokerXmlConfig"/>

                         <connection-definition

                          class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory"

                          jndi-name="java:jboss/activemq/TopicConnectionFactory" pool-name="TopicConnectionFactory">

                           <xa-pool>

                            <min-pool-size>1</min-pool-size>

                            <max-pool-size>200</max-pool-size>

                            <prefill>false</prefill>

                            <use-strict-min>false</use-strict-min>

                            <flush-strategy>FailingConnectionOnly</flush-strategy>

                            <pad-xid>false</pad-xid>

                            <wrap-xa-resource>true</wrap-xa-resource>

                          </xa-pool>

                          <security>

                              <application />

                          </security>

                          <timeout>

                              <blocking-timeout-millis>30000</blocking-timeout-millis>

                              <idle-timeout-minutes>3</idle-timeout-minutes>

                          </timeout>

                          <validation>

                              <background-validation>false</background-validation>

                              <use-fast-fail>false</use-fast-fail>

                          </validation>

                      </connection-definition>

                      <connection-definition

                          class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory"

                          jndi-name="java:jboss/activemq/QueueConnectionFactory" pool-name="QueueConnectionFactory">

                           <xa-pool>

                            <min-pool-size>1</min-pool-size>

                            <max-pool-size>200</max-pool-size>

                            <prefill>false</prefill>

                            <use-strict-min>false</use-strict-min>

                            <flush-strategy>FailingConnectionOnly</flush-strategy>

                            <pad-xid>false</pad-xid>

                            <wrap-xa-resource>true</wrap-xa-resource>

                          </xa-pool>

                          <security>

                              <application />

                          </security>

                          <timeout>

                              <blocking-timeout-millis>30000</blocking-timeout-millis>

                              <idle-timeout-minutes>3</idle-timeout-minutes>

                          </timeout>

                          <validation>

                              <background-validation>false</background-validation>

                              <use-fast-fail>false</use-fast-fail>

                          </validation>

                      </connection-definition>

                      <admin-objects>

                          <admin-object class-name="org.apache.activemq.command.ActiveMQQueue"

                                              jndi-name="activemq/queue/CBtoDP" enabled="true"

                                              use-java-context="true" pool-name="queueCBtoDP">

                              <config-property name="PhysicalName">queueCBtoDP

                              </config-property>

                          </admin-object>

                      </admin-objects>

                      </resource-adapter>

                  </resource-adapters>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:sar:1.0"/>

              <subsystem xmlns="urn:jboss:domain:security:1.1">

                  <security-domains>

                      <security-domain name="other" cache-type="default">

                          <authentication>

                              <login-module code="Remoting" flag="optional">

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                              <login-module code="RealmUsersRoles" flag="required">

                                  <module-option name="usersProperties" value="${jboss.server.config.dir}/application-users.properties"/>

                                  <module-option name="rolesProperties" value="${jboss.server.config.dir}/application-roles.properties"/>

                                  <module-option name="realm" value="ApplicationRealm"/>

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                          </authentication>

                      </security-domain>

                      <security-domain name="jboss-web-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                      <security-domain name="jboss-ejb-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                  </security-domains>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:threads:1.1"/>

              <subsystem xmlns="urn:jboss:domain:transactions:1.1">

                  <core-environment>

                      <process-id>

                          <uuid/>

                      </process-id>

                  </core-environment>

                  <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

                  <coordinator-environment default-timeout="300"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false">

                  <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                    <virtual-server name="default-host" enable-welcome-root="true">

                      <alias name="localhost"/>

                  </virtual-server>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:webservices:1.1">

                  <modify-wsdl-address>true</modify-wsdl-address>

                  <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>

                  <endpoint-config name="Standard-Endpoint-Config"/>

                  <endpoint-config name="Recording-Endpoint-Config">

                      <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">

                          <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>

                      </pre-handler-chain>

                  </endpoint-config>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:weld:1.0"/>

          </profile>

       

          <interfaces>

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>

              </interface>

              <interface name="public">

                  <inet-address value="${jboss.bind.address:127.0.0.1}"/>

              </interface>

              <interface name="unsecure">

                  <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>

              </interface>

          </interfaces>

       

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

              <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>

              <socket-binding name="ajp" port="8009"/>

              <socket-binding name="http" port="8080"/>

              <socket-binding name="https" port="8443"/>

              <socket-binding name="osgi-http" interface="management" port="8090"/>

              <socket-binding name="remoting" port="4447"/>

              <socket-binding name="txn-recovery-environment" port="4712"/>

              <socket-binding name="txn-status-manager" port="4713"/>

              <outbound-socket-binding name="mail-smtp">

                  <remote-destination host="localhost" port="25"/>

              </outbound-socket-binding>

          </socket-binding-group>

       

      </server>

      {code}