1 Reply Latest reply on Jul 31, 2012 4:58 AM by Wolf-Dieter Fink

    Regarding Https compression not working in jboss 5.1 GA

    rupesh kumar Newbie

      I have changed http port 8080 to port 80 and SSL port from 8443 to 443

       

      i have also configure Https port and add compression , please find below configured file..

       

      Server>

       

         <!-- Optional listener which ensures correct init and shutdown of APR,

              and provides information if it is not installed -->

         <Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />

         <!--Initialize Jasper prior to webapps are loaded. Documentation at /docs/jasper-howto.html -->

         <Listener className="org.apache.catalina.core.JasperListener" />

       

         <Service name="jboss.web">

       

            <!-- A HTTP/1.1 Connector on port 8080 -->

            <Connector protocol="HTTP/1.1" port="80" address="${jboss.bind.address}" compression="force"

             noCompressionUserAgents="gozilla, traviata"

               compressableMimeType="text/html,text/xml,text/css,text/javascript,application/x-javascript,application/javascript,image/svg+xml,text/json,gzip"

             connectionTimeout="20000" redirectPort="443" />

       

            <!-- Add this option to the connector to avoid problems with

                .NET clients that don't implement HTTP/1.1 correctly

               restrictedUserAgents="^.*MS Web Services Client Protocol 1.1.4322.*$"

            -->

       

            <!-- A AJP 1.3 Connector on port 8009 -->

            <Connector protocol="AJP/1.3" port="8009" address="${jboss.bind.address}"

               redirectPort="443" />

       

            <!-- SSL/TLS Connector configuration using the admin devl guide keystore -->

            <Connector protocol="HTTP/1.1" SSLEnabled="true"

                 port="443" address="${jboss.bind.address}"

                 maxThreads="20" strategy="ms" maxHttpHeaderSize="8192"

                 emptySessionPath="true"

                   compressableMimeType="text/html,text/xml,text/css,text/javascript,application/x-javascript,application/javascript,image/svg+xml,text/json,gzip"

                 compression="force"

                 scheme="https" secure="true" clientAuth="false"

                 keystoreFile="${jboss.server.home.dir}/conf/chap8.keystore"

                 keystorePass="rmi+ssl" sslProtocol = "TLS" />

       

       

            <Engine name="jboss.web" defaultHost="localhost">

       

       

      But still issue not resolved on https but in http the content is showing compressed with wbox command

       

      i check the compressed content with wbox command utility

       

      [monitor@app classes]$ wbox http://192.168.149.24:80/cdotmain/ compr

      WBOX 192.168.149.24 (192.168.149.24) port 80 [compr]

      0. 200 OK    781 bytes    1 ms    compr

      1. 200 OK    781 bytes    1 ms    compr

      2. 200 OK    781 bytes    1 ms    compr

      3. 200 OK    781 bytes    1 ms    compr

       

      And then check on on Https when application redirect from port 80 to 443.

       

      [monitor@app classes]$ wbox https://192.168.149.24:443/TMRS/ compr

      WBOX 192.168.149.24 (192.168.149.24) port 443 [compr]

      0. 0 ()    7 bytes    1 ms

      1. 0 ()    7 bytes    0 ms

      2. 0 ()    7 bytes    0 ms

      3. 0 ()    7 bytes    0 ms

      4. 0 ()    7 bytes    0 ms

      5. 0 ()    7 bytes    0 ms

       

       

      Please suggest

      thanks.