0 Replies Latest reply on Aug 6, 2012 10:12 AM by Chad Sturtz

    Guvnor DRL Import Failure

    Chad Sturtz Newbie

      I'm importing large DRL files into Guvnor (5000 rules in each file).  A few times now I've run into the same issue and can only get past it by wiping the package. Full story...

       

      I've got about 50,000 rules I want to put in a single package as they're all vey closely related.  I'm importing 5000 rules at a time (each one takes a few hours, ugh).  On my 3rd file, the import failed because a rule name contained a colon in the middle.. something like "my rule : subcategory".  I resolved the issue in the DRL file and re-imported the file.  The problem is that now the import is failing for another reason.  I'm getting this error message:

       

      Unable to import into the package. Unable to process import: An asset of that name already exists in the module.

       

       

      I've double checked that no rules in the file have the same name as I though that might be the case.  Searching online is not proving to be any help.  All I can think of is that Guvnor is not cleanly exiting the first import.  This wouldn't surprise me considering that even when a large DRL file import is successful, I frequently have to restart the server because I start getting 500 HTTP responses and the jboss console window is full of errors and warnings.

       

      What I'd like to know is if there's any way to resolve this issue without wiping the whole package.  Each one of these imports takes several hours, so I don't want to have to start from scratch again.

       

      Any help would be appreciated.

       

      Thanks!

       

       

      UPDATE - I tried archiving the entire pacakge and then restoring it, but am running into the same error - and along the way, ran into some other issues as well