2 Replies Latest reply on Jun 7, 2013 3:26 AM by Tomas Remes

    Rendered attribute not working on seam 2.3.0 UI components

    Charles Akalugwu Newbie

      Hi Guys,

       

      I am encountering a very strange issue with my seam components. First of all, the following are my project specifications:

       

      JBoss Seam 2.3.0 Beta2

      Primefaces 3.4

      JSF 2.1.11

      Facelets 1.1.15

      JBoss 7.2.0

       

       

      The problem is that the rendered attribute on my seam components (s:div for example) are not working. I created a simple page to test this:

       

      <!DOCTYPE html>

      <html xmlns="http://www.w3.org/1999/xhtml"

            xmlns:h="http://java.sun.com/jsf/html"

            xmlns:f="http://java.sun.com/jsf/core"

            xmlns:ui="http://java.sun.com/jsf/facelets"

            xmlns:fb="https://www.facebook.com/2008/fbml"

            xmlns:s="http://jboss.com/products/seam/taglib"

            xmlns:p="http://primefaces.org/ui">

       

       

                <h:head>

       

                          <title>Test</title>

       

                          <h:outputScript library="primefaces" name="jquery/jquery.js" />

       

                </h:head>

       

       

                <h:body>

       

                              <s:div rendered="false" style="font-size: 20px;">Seam</s:div>

                              <h:outputText value="JSF" rendered="false" />

                              <p:outputPanel rendered="false">Primefaces</p:outputPanel>

       

                </h:body>

      </html>

       

       

      The result is that the content of the s:div tag is rendered even though the rendered attribute explicitly states false. The regular JSF and the primefaces components work as expected. Is anyone else having such an issue? Thanks.

       

      Charlie