7 Replies Latest reply on Aug 9, 2012 5:58 AM by Eero Mäkelä

    Alerts not firing in RHQ

    Eero Mäkelä Newbie

      Hi all,

      I have a problem of alerts not firing in RHQ. I have created several alerts for several different measurements, and I never get any alerts to the Alerts History of any resource.

       

      Is there some "master" switch to turn alerts on, or why am I not getting any alerts in RHQ?

       

      I am running RHQ Version: 4.5.0-SNAPSHOT.

       

      For example, I took the following steps to create a silly test alert:

      • Choose a platform in Inventory
      • Alerts->Definitions -> New -> Gave a name and description "TestAlert", Priority "High", Enabled "Yes"
      • Conditions->Add "Measurement Absolute Value Threshold", Metric "Actual Free Memory" > (Greater Than) 1MB
      • Save

       

      Then under the same platform I chose Monitoring to see the Last value for Actual Free Memory is 7.6869GB. I click Schedules to see that Actual Free Memory is enabled and Collection Interval is 10 minutes. I changed the Collection Interval to 2 minutes.

       

      After several minutes, I still don't get any alerts to the Alerts History.

       

      I have tried this also with some other resources such as Metric Value Change of Message Count in a service under a JBoss ESB, and verified that the message count increases as I run messages through my system, but the alert never fires. (These are, of course, not very useful meaurements to set alerts on, but I'd like to see at least some alerts working before defining the real ones).

       

      I have also tried to add notifications to the alerts so that it would send emails, but no emails are sent (as expected, since the alerts are not fired).

       

      Thank you for any advice.