4 Replies Latest reply on Jun 28, 2013 4:36 AM by Gerhard Visagie

    Unable to deploy Resource Adaptor to JBoss EAP 6 (Steropes, 7.1.2)

    Srini Dhanam Newbie

      We are moving our web services application from JBoss 4.2.3 to JBoss EAP 6.  One of the component of the application is a JCA compliant (we think) Resource Adaptor that interacts with the ISeries databases and programs.  This adapter deploys and works fine in JBoss 4.2.3.  Now I am trying to deploy to JBoss EAP 6.  These are the steps I followed:

       

      1.  Create a module for the dependencies (module.xml etc.).

      2.  Modify the MANIFEST.MF in the .rar file and added the dependencies.

      3.  Modified the standalone.xml and added the configuration for the RA under the RA subsystem.

      4.  Copied over the .rar file to standalone/deployments.

       

      When I start the server, I get the following:

       

       

      11:53:46,316 INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-1) JBAS010406: Registered connection factory java:/AS400Pcml/777 11:53:46,338 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC000001: Failed to start service jboss.ra.deployment."AS400SystemAdapter.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."AS400SystemAdapter.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [AS400SystemAdapter]         at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:128)         at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]         at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05]         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05]         at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05] Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [AS400SystemAdapter]         at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:112)         ... 5 more Caused by: org.jboss.jca.deployers.common.DeployException: IJ020056: Deployment failed: file:/opt/app/jboss-eap-6.0/standalone/tmp/vfs/temp5e31459415832dac/AS400SystemAdapter.rar-2c771fe79eb21291/contents/         at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:2198)         at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService$AS7RaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:179)         at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:105)         ... 5 more Caused by: org.jboss.jca.validator.ValidatorException: Severity: ERROR Section: 17.5.1.1 Description: A ConnectionFactory must have a default constructor         ... 8 more

       

      The CF has a default constructor.

       

      Help Please......

       

      Thanks,

       

      Srini