2 Replies Latest reply on Aug 14, 2012 12:10 PM by Constantino Lojero

    JBoss CLI remote connect not working

    Constantino Lojero Newbie

      Hi, im new to Jboss AS7 and evaluating it for implementation, I just made a fresh install of JBoss AS 7.1.1.Final "Brontes" in Ubuntu 12.04 64bits(server edition), everything is ok, but my problem is that I cant connect remotely using "jboss-cli.sh" (I can do it localy), the server has the next configuration:

       

      JBOSS_HOME: /opt/jboss-as

      JBoss AS release: 7.1.1.Final "Brontes"

      os.name: Linux

      os.version: 3.2.0-23-generic

       

      Java Version:

      java version "1.6.0_26"

      Java(TM) SE Runtime Environment (build 1.6.0_26-b03)

      Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

       

      I have already modified interface in standalone.xml as follow:

      <interface name="management">

      <any-ipv4-address/>

      </interface>

       

      I am able to connect remotely to console at port 9990, but not using jboss-cli in port 9999, every attempt to connect through cli results in the next line in server.log:

      ERROR [org.jboss.remoting.remote.connection] (Remoting "ps-sim2:MANAGEMENT" read-1) JBREM000200: Remote connection failed: java.io.IOException: Connection reset by peer

       

      I have searched for similar situations but not lucky, the most similar situation is for people using JDK 7, but this is not the case, hope someone cant point me where I can look to get the solution.

      Thanks in advanced.

        • 1. Re: JBoss CLI remote connect not working
          Nicklas Karlsson Master

          can you do a telnet to port 9999 (is the port open)? Any firewalls in between (try telnetting from localhost and an external machine)? Tried with any-address? SELinux enabled?

          1 of 1 people found this helpful
          • 2. Re: JBoss CLI remote connect not working
            Constantino Lojero Newbie

            Thanks a lot for the reply, I have already done this and the port is open, also I checked for firewalls in the middle, there is nothing, i have already tried with <any-address/> and <inet-address value="0.0.0.0"/> and the result is the same.

             

            I made a fresh install with same characteristics on a PC and it worked perfectly, I can connect remotely, the only difference between this two environments is that one is a physical pc and the other one is in a virtual machine (Oracle VM to be more precisely), thoerically it shouldn't be any difference but...

             

            I'm running out of ideas... but I will still trying to at least know why is not working on the VM.

            Thanks.