0 Replies Latest reply on Aug 14, 2012 11:35 AM by Alessandro Gelormini

    Very strange and annoying problem with hibernate

    Alessandro Gelormini Newbie

      Hi i have encountered this big problem and cannot resolve....I have 3 jboss at work:one is the official in production,second is on a test machine,third is on my local pc....i modifed a production module (with ejb and hibernate) to add new functionalities...the problem is: all of the server are the same (jboss 4.2.3) with same db and same settings....but ifi deploy my new jar in local and test server is all ok...if i put same jar in production server i cannot read anymore from db using client (the screen which should show datas is blank)....no errors on jboss log neither on client console....the only things that appears everytime i tried to get data are these (but remember, only in production server):

       

      WARN  [org.hibernate.engine.loading.LoadContexts] fail-safe cleanup (collections) : org.hibernate.engine.loading.CollectionLoadContext@a6dc17<rs=org.postgresql.jdbc3.Jdbc3ResultSet@dbd250>

       

      WARN  [org.hibernate.engine.loading.CollectionLoadContext] On CollectionLoadContext#cleanup, localLoadingCollectionKeys contained [1] entries

       

       

      i tried to restart server,modify other things but nothin changed....the strange thing is that on test servers all is going well (also with hot deployment)

      i'm getting crazy