4 Replies Latest reply on Mar 26, 2013 3:34 AM by Hema Markish

    JBoss 7 + Apache + mod_cluster 1.2.0.Final

    Viggo Navarsete Expert

      Hi,

       

      I have installed JBoss 7.2.0.Alpha1-SNAPSHOT (also tried with 7.1.1.Final), and setup Apache with mod_cluster 1.2.0.Final, and JBoss starts to output this every 10 seconds:

      14:29:28,082 ERROR [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Error [null: null: {4}] sending command INFO to proxy localhost/127.0.0.1:6666, configuration will be reset

       

      Any clue?

       

      What I did:

      1. Downloaded mod cluster 1.2.0.Final from here: http://downloads.jboss.org/mod_cluster//1.2.0.Final/mod_cluster-1.2.0.Final-linux2-x64-so.tar.gz

      2. Copied the 4 files (mod_slotmem.so, mod_proxy_cluster.so, mod_manager.so, mod_advertise.so) to /usr/lib/apache2/modules

      3. Added the following snippet to the end of the VirtualHost definition in /etc/apache2/sites-available/default:

             <Location /mod_cluster-manager>

                 SetHandler mod_cluster-manager

                 Order deny,allow

                 Deny from all

                 Allow from all

             </Location>

      4. Run the command: sudo /etc/init.d/apache2 reload

      5. I'm able to access this page: http://localhost/mod_cluster-manager,and the only thing showing is:

      Auto Refresh show DUMP output show INFO output

      6. I downloaded JBoss JBoss 7.1.1.Final and made two copies of it:

      /opt/jboss7_clustering/master

      /opt/jboss7_clustering/slave

      7. Started the master with: ./bin/standalone.sh -Djboss.node.name=master --server-config=standalone-ha.xml

      8. Started the slave with: ./bin/standalone.sh -Djboss.node.name=slave --server-config=standalone-ha.xml -Djboss.socket.binding.port-offset=100

      9. server.log from master: http://pastebin.com/DX184SBc

      10. server.log from slave: http://pastebin.com/bZKyYqMg