0 Replies Latest reply on Aug 21, 2012 10:26 AM by Fidel Andrés Vargas Londoño

    JBoss 6.1 and mod_jk problems

    Fidel Andrés Vargas Londoño Newbie

      Hi Everybody

       

       

      We had six-nodes Jboss Cluster working with mod_jk and apache http server running on SLES.

       

       

      We migrated from Jboss 4.2.3  to a Jboss 6.1, having every considerations that this requires. However now something is happening. The application supports over 200 concurrent request but every day not at the same hour, mod_jk fails, and it doesn´t send requests for the Jboss for two or three minutes and after It works and everything works fine. Reviewing the apache logs there is nothing but looking, the mod_jk logs I can see the follow error for all nodes:

       

       

      [info] ajp_send_request::jk_ajp_common.c (1496): (node6) all endpoints are disconnected, detected by connect check (1), cping (0), send (0)

      [info] jk_open_socket::jk_connect.c (594): connect to <here the ip>:8009 failed (errno=111)

      [info] ajp_connect_to_endpoint::jk_ajp_common.c (922): Failed opening socket to (<here the ip>:8009) (errno=111)

      [error] ajp_send_request::jk_ajp_common.c (1507): (node5) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)

      [info] ajp_service::jk_ajp_common.c (2447): (node5) sending request to tomcat failed (recoverable), because of error during request sending (attempt=1)

      [info] jk_open_socket::jk_connect.c (594): connect to <here the ip>:8009 failed (errno=111)

      [info] ajp_connect_to_endpoint::jk_ajp_common.c (922): Failed opening socket to (<here the ip>:8009) (errno=111)

      [error] ajp_send_request::jk_ajp_common.c (1507): (node3) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)

      [info] ajp_service::jk_ajp_common.c (2447): (node3) sending request to tomcat failed (recoverable), because of error during request sending (attempt=2)

      [error] ajp_service::jk_ajp_common.c (2466): (node3) connecting to tomcat failed.

      [info] service::jk_lb_worker.c (1384): service failed, worker node6 is in error state

      [info] ajp_send_request::jk_ajp_common.c (1496): (node4) all endpoints are disconnected, detected by connect check (1), cping (0), send (0)

      [info] jk_open_socket::jk_connect.c (594): connect to <here the ip>:8009 failed (errno=111)

      [info] ajp_connect_to_endpoint::jk_ajp_common.c (922): Failed opening socket to (<here the ip>:8009) (errno=111)

      [error] ajp_send_request::jk_ajp_common.c (1507): (node4) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)

      [info] ajp_service::jk_ajp_common.c (2447): (node4) sending request to tomcat failed (recoverable), because of error during request sending (attempt=1)

      [info] jk_open_socket::jk_connect.c (594): connect to <here the ip>:8009 failed (errno=111)

      [info] ajp_connect_to_endpoint::jk_ajp_common.c (922): Failed opening socket to (<here the ip>:8009) (errno=111)

       

       

      These kind of errors occurs when Jboss doesn´t send the response, but this is not the case because when this happens I login in Jboss and is working fine. The immediate solution for the problem is restart the apache service or wait it return  its state. The apache process and the SO logs doesn´t show anything I dont know what is the cause of the problem.

       

      I think the problem happens when the app reaches the top of concurrent requests per day but the cause and the solution I dont know.

       

      for the time being we are going to try to migrate mod_cluster but we don´t know if this works.

       

      Thanks who can help me.

       

      Bye