1 Reply Latest reply on Aug 22, 2012 7:56 AM by Paul Dijou

    Sematics components naming conventions

    Lukáš Fryč Master

      Hi guys,

       

      we have been using naming convention for semantic components as <prefix>Facet so far,

      but I don't consider this convention as fortunate.

       

      ----

       

      In case of semantic components which may potentially clash with their conterparts from HTML5/JSF it is logical, e.g.

       

      b:bodyFacet

      b:headerFacet

       

      Facets meant to be customizable parts of the top-level components.

       

      ----

       

      However there are sematic components which introduces meaning on their own:

       

      b:separatorFacet

       

      could be rather

       

      b:separator.

        • 1. Re: Sematics components naming conventions
          Paul Dijou Newbie

          I disagree. "b:separator" should be a component of its own, not a semantic one, like a <hr/> tag with more options. It's important to keep the "Facet" suffix IMO because it tells people "Warning, this is not a real component, only use it inside another component supporting it". If a new user was seeing a "b:separator" component, he would probably feel conforable with using it anywhere and wouldn't understand to have an exception. And he would be right.