0 Replies Latest reply on Apr 7, 2002 7:31 AM by Gerard Smyth

    Problems after changing from 2.4.3 to 2.4.4

    Gerard Smyth Newbie

      I recently changed from using jboss 2.4.3 to version 2.4.4 to solve a delay problem that was probably caused by a memory leak in 2.4.3. Since doing so however, I am getting a lot of problems with code that worked fine on the original version.

      Session bean methods seem to take much longer to complete (by an order of magnitude!) and I am getting much more out of memory errors, although without any stack traces.

      Another problem occurs when trying to look at the results of a findAll query (Using CMP 1.1 for the entity beans). If i try an iterate through the resulting collection, it nearly always crashes at some random entry with a find failed - nested exception, null pointer exception. For the entry at which it crashes, if I log the narrowed remote reference, I get the object type, and the primary key toString method, but if I try and call any get method it gives the error.

      I really don't know why I am getting these errors, especially as all the code worked fine with 2.4.3 (except for the delay) and so any help would be greatly appreciated!

      Cheers,

      Gerard