4 Replies Latest reply on Aug 26, 2012 10:31 PM by rhunt

    mod_cluster issue after JBoss restart

    rhunt Newbie

      I am running mod_cluster 1.2.0.Final (under Apache) with JBoss EAP 6.  When I first start Apache and JBoss everything works fine, but after restarting JBoss all attempts to access the application result in a 503 error until Apache is restarted as well.  I think my httpd configuration is fairly standard:

       

      <IfModule manager_module>

        Listen *:6666

        <VirtualHost *:6666>

          <Location />

           Order deny,allow

           Allow from all

          </Location>

       

          KeepAliveTimeout 300

          MaxKeepAliveRequests 0

          AdvertiseGroup 239.255.100.102

          EnableMCPMReceive

                LogLevel debug

       

          <Location /mod_cluster_manager>

             SetHandler mod_cluster-manager

             Order deny,allow

             Allow from all

          </Location>

       

        </VirtualHost>

      </IfModule>

       

      as is my modcluster configuration in JBoss (my modcluster socket-binding has been modified to use the same multicast address as in the AdvertiseGroup above):

       

              <subsystem xmlns="urn:jboss:domain:modcluster:1.1">

                  <mod-cluster-config advertise-socket="modcluster" connector="ajp">

                      <dynamic-load-provider>

                          <load-metric type="busyness"/>

                      </dynamic-load-provider>

                  </mod-cluster-config>

              </subsystem>

       

      My issue unfolds like this:

       

      1.  I start both Apache and JBoss and everything hooks up correctly - I can see my node in mod_cluster_manager and application requests work.  Hooray!

      2.  Upon shutting down JBoss I see the expected DISABLE-APP, STOP-APP and REMOVE-APP messages in my httpd logs and my node no longer displays in mod_cluster_manager.  So far this is still what I expect.

      3.  When I restart JBoss I see the following messages in my httpd logs and my node re-appears in mod_cluster_manager.  So far so good.

       

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(1667): manager_trans INFO (/)

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(2323): manager_handler INFO (C:/) processing: ""

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(2366): manager_handler INFO  OK

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(1667): manager_trans CONFIG (/)

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(2323): manager_handler CONFIG (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Host=WLG-MAFAPWEB05&Maxattempts=1&Port=8009&StickySessionForce=No&Type=ajp&ping=10"

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(2366): manager_handler CONFIG  OK

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(1667): manager_trans STATUS (/)

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(2323): manager_handler STATUS (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Load=100"

      [Thu Aug 23 11:35:37 2012] [debug] mod_manager.c(1404): Processing STATUS

      [Thu Aug 23 11:35:37 2012] [debug] proxy_util.c(2011): proxy: ajp: has acquired connection for (wlg-mafapweb05)

      [Thu Aug 23 11:35:37 2012] [debug] proxy_util.c(2067): proxy: connecting ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

      [Thu Aug 23 11:35:37 2012] [debug] proxy_util.c(2193): proxy: connected ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

      [Thu Aug 23 11:35:37 2012] [debug] proxy_util.c(2444): proxy: ajp: fam 2 socket created to connect to wlg-mafapweb05

      [Thu Aug 23 11:35:38 2012] [debug] mod_proxy_cluster.c(773): ajp_cping_cpong: Done

      [Thu Aug 23 11:35:38 2012] [debug] proxy_util.c(2029): proxy: ajp: has released connection for (wlg-mafapweb05)

      [Thu Aug 23 11:35:38 2012] [debug] mod_manager.c(2366): manager_handler STATUS  OK

      [Thu Aug 23 11:35:38 2012] [debug] mod_proxy_cluster.c(678): update_workers_node starting

      [Thu Aug 23 11:35:38 2012] [debug] mod_proxy_cluster.c(693): update_workers_node done

      [Thu Aug 23 11:35:42 2012] [debug] mod_manager.c(1667): manager_trans ENABLE-APP (/)

      [Thu Aug 23 11:35:42 2012] [debug] mod_manager.c(2323): manager_handler ENABLE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-scanner"

      [Thu Aug 23 11:35:42 2012] [debug] mod_manager.c(2366): manager_handler ENABLE-APP  OK

      [Thu Aug 23 11:35:48 2012] [debug] mod_manager.c(1667): manager_trans STATUS (/)

      [Thu Aug 23 11:35:48 2012] [debug] mod_manager.c(2323): manager_handler STATUS (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Load=100"

      [Thu Aug 23 11:35:48 2012] [debug] mod_manager.c(1404): Processing STATUS

      [Thu Aug 23 11:35:48 2012] [debug] proxy_util.c(2011): proxy: ajp: has acquired connection for (wlg-mafapweb05)

      [Thu Aug 23 11:35:48 2012] [debug] proxy_util.c(2067): proxy: connecting ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

      [Thu Aug 23 11:35:48 2012] [debug] proxy_util.c(2193): proxy: connected ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

      [Thu Aug 23 11:35:48 2012] [debug] mod_proxy_cluster.c(773): ajp_cping_cpong: Done

      [Thu Aug 23 11:35:48 2012] [debug] proxy_util.c(2029): proxy: ajp: has released connection for (wlg-mafapweb05)

      [Thu Aug 23 11:35:48 2012] [debug] mod_manager.c(2366): manager_handler STATUS  OK

       

      4.  Unfortunately, when I attempt to access the application I now get 503 errors and see the following in my httpd logs.  This behaviour persists until I restart Apache.

       

      [Thu Aug 23 11:40:01 2012] [error] proxy: CLUSTER: (balancer://mycluster). All workers are in error state

       

      There are no other messages in the log preceding this to indicate what might be going on, nor is there anything of interest in the JBoss logs.  Can anyone help?

       

      The only thing I can see that 'may' be contributing is the JBoss EAP 6 claims to be running version 1.2.1.Final of mod_cluster - could there be any version conflicts between this and 1.2.0.Final running on Apache?  I cannot alter what JBoss is running and have been unable to find a 1.2.1 release to download for Apache.

        • 1. Re: mod_cluster issue after JBoss restart
          Jean-Frederic Clere Master

          LogLevel debug is in the VirtualHost the request/reponse are outside or in another VirtualHost so we can't see what is going wrong.

          The part of the log above looks OK it should have worked.

          1 of 1 people found this helpful
          • 2. Re: mod_cluster issue after JBoss restart
            rhunt Newbie

            Thanks for the quick response - I should have noticed I'd only enabled logging for the virtual host.  I'm home for the weekend now but will try and turn more logging on on Monday and see how I go.

            • 3. Re: mod_cluster issue after JBoss restart
              rhunt Newbie

              So after turning on more debug logging I'm not really any closer to resolving the issue.  For successful requests (prior to restarting JBoss) I see the following log output:

               

              [Mon Aug 27 09:19:01 2012] [debug] mod_proxy_cluster.c(1954): cluster: Found value kfgWYATYANH7eonwiuLLzShr.f261431e-7879-3c7e-9aec-f01bc9542c5d for stickysession JSESSIONID|jsessionid

              [Mon Aug 27 09:19:01 2012] [debug] mod_proxy_cluster.c(2338): cluster: Using route f261431e-7879-3c7e-9aec-f01bc9542c5d

              [Mon Aug 27 09:19:01 2012] [debug] mod_proxy.c(1020): Running scheme balancer handler (attempt 0)

              [Mon Aug 27 09:19:01 2012] [debug] mod_proxy_ajp.c(681): proxy: AJP: serving URL ajp://wlg-mafapweb05:8009/e-cert-information/ecert

              [Mon Aug 27 09:19:01 2012] [debug] proxy_util.c(2011): proxy: AJP: has acquired connection for (wlg-mafapweb05)

              .....(More logging representing a successful request)

               

              After restarting JBoss I see all of the ENABLE-APP traffic (already posted above) and the following additional debug logging when attempt to access the application

               

              [Mon Aug 27 09:22:17 2012] [debug] mod_proxy_cluster.c(1954): cluster: Found value kfgWYATYANH7eonwiuLLzShr.f261431e-7879-3c7e-9aec-f01bc9542c5d for stickysession JSESSIONID|jsessionid

              [Mon Aug 27 09:22:17 2012] [debug] mod_proxy_cluster.c(2338): cluster: Using route f261431e-7879-3c7e-9aec-f01bc9542c5d

              [Mon Aug 27 09:22:17 2012] [debug] mod_proxy_cluster.c(1543): proxy: byrequests balancer FAILED

              [Mon Aug 27 09:22:17 2012] [error] proxy: CLUSTER: (balancer://mycluster). All workers are in error state

               

              Any ideas?  For completeness, here's the entire log from the point JBoss is shut down - there's multiple web applications so it's a little verbose:

               

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans DISABLE-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler DISABLE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fuser-admin-web"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler DISABLE-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans STOP-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler STOP-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fuser-admin-web"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler STOP-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans REMOVE-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler REMOVE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fuser-admin-web"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler REMOVE-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans DISABLE-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler DISABLE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-information"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler DISABLE-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans STOP-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler STOP-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-information"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler STOP-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans REMOVE-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler REMOVE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-information"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler REMOVE-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans DISABLE-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler DISABLE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-scanner"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler DISABLE-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans STOP-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler STOP-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-scanner"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler STOP-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans REMOVE-APP (/)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler REMOVE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-scanner"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler REMOVE-APP  OK

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1667): manager_trans REMOVE-APP (/*)

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2323): manager_handler REMOVE-APP (C:/NODE_COMMAND) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d"

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(1143): process_node_cmd 4 processing node: 1

              [Mon Aug 27 09:21:33 2012] [debug] mod_manager.c(2366): manager_handler REMOVE-APP  OK

              [Mon Aug 27 09:21:34 2012] [debug] mod_proxy_cluster.c(678): update_workers_node starting

              [Mon Aug 27 09:21:34 2012] [debug] mod_proxy_cluster.c(693): update_workers_node done

              [Mon Aug 27 09:21:34 2012] [debug] mod_proxy_cluster.c(604): remove_workers_node (helper) 0 f261431e-7879-3c7e-9aec-f01bc9542c5d

              [Mon Aug 27 09:21:34 2012] [debug] mod_proxy_cluster.c(678): update_workers_node starting

              [Mon Aug 27 09:21:34 2012] [debug] mod_proxy_cluster.c(693): update_workers_node done

              [Mon Aug 27 09:21:34 2012] [debug] mod_proxy_cluster.c(678): update_workers_node starting

              [Mon Aug 27 09:21:34 2012] [debug] mod_proxy_cluster.c(693): update_workers_node done

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(1667): manager_trans INFO (/)

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(2323): manager_handler INFO (C:/) processing: ""

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(2366): manager_handler INFO  OK

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(1667): manager_trans CONFIG (/)

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(2323): manager_handler CONFIG (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Host=WLG-MAFAPWEB05&Maxattempts=1&Port=8009&StickySessionForce=No&Type=ajp&ping=60"

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(2366): manager_handler CONFIG  OK

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(1667): manager_trans ENABLE-APP (/)

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(2323): manager_handler ENABLE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-scanner"

              [Mon Aug 27 09:22:04 2012] [debug] mod_manager.c(2366): manager_handler ENABLE-APP  OK

              [Mon Aug 27 09:22:05 2012] [debug] mod_manager.c(1667): manager_trans STATUS (/)

              [Mon Aug 27 09:22:05 2012] [debug] mod_manager.c(2323): manager_handler STATUS (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Load=100"

              [Mon Aug 27 09:22:05 2012] [debug] mod_manager.c(1404): Processing STATUS

              [Mon Aug 27 09:22:05 2012] [debug] mod_proxy_cluster.c(258): Created: reusing worker for ajp://WLG-MAFAPWEB05:8009

              [Mon Aug 27 09:22:05 2012] [debug] mod_proxy_cluster.c(360): proxy: initialized worker 1 in child 1396 for (wlg-mafapweb05) min=0 max=64 smax=64

              [Mon Aug 27 09:22:05 2012] [debug] mod_proxy_cluster.c(418): Created: worker for ajp://WLG-MAFAPWEB05:8009 1 (status): 1

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2011): proxy: ajp: has acquired connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2067): proxy: connecting ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:05 2012] [debug] mod_proxy_cluster.c(678): update_workers_node starting

              [Mon Aug 27 09:22:05 2012] [debug] mod_proxy_cluster.c(693): update_workers_node done

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2011): proxy: ajp: has acquired connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2067): proxy: connecting ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2193): proxy: connected ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2193): proxy: connected ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2444): proxy: ajp: fam 2 socket created to connect to wlg-mafapweb05

              [Mon Aug 27 09:22:05 2012] [debug] proxy_util.c(2444): proxy: ajp: fam 2 socket created to connect to wlg-mafapweb05

              [Mon Aug 27 09:22:06 2012] [debug] mod_proxy_cluster.c(773): ajp_cping_cpong: Done

              [Mon Aug 27 09:22:06 2012] [debug] proxy_util.c(2029): proxy: ajp: has released connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:06 2012] [debug] mod_proxy_cluster.c(678): update_workers_node starting

              [Mon Aug 27 09:22:06 2012] [debug] mod_proxy_cluster.c(693): update_workers_node done

              [Mon Aug 27 09:22:06 2012] [debug] mod_proxy_cluster.c(678): update_workers_node starting

              [Mon Aug 27 09:22:06 2012] [debug] mod_proxy_cluster.c(693): update_workers_node done

              [Mon Aug 27 09:22:06 2012] [debug] mod_proxy_cluster.c(773): ajp_cping_cpong: Done

              [Mon Aug 27 09:22:06 2012] [debug] proxy_util.c(2029): proxy: ajp: has released connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:06 2012] [debug] mod_manager.c(2366): manager_handler STATUS  OK

              [Mon Aug 27 09:22:09 2012] [debug] mod_manager.c(1667): manager_trans ENABLE-APP (/)

              [Mon Aug 27 09:22:09 2012] [debug] mod_manager.c(2323): manager_handler ENABLE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fe-cert-information"

              [Mon Aug 27 09:22:09 2012] [debug] mod_manager.c(2366): manager_handler ENABLE-APP  OK

              [Mon Aug 27 09:22:10 2012] [debug] mod_manager.c(1667): manager_trans ENABLE-APP (/)

              [Mon Aug 27 09:22:10 2012] [debug] mod_manager.c(2323): manager_handler ENABLE-APP (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Alias=default-host%2Clocalhost%2Cexample.com&Context=%2Fuser-admin-web"

              [Mon Aug 27 09:22:10 2012] [debug] mod_manager.c(2366): manager_handler ENABLE-APP  OK

              [Mon Aug 27 09:22:10 2012] [debug] proxy_util.c(2011): proxy: ajp: has acquired connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:10 2012] [debug] proxy_util.c(2067): proxy: connecting ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:10 2012] [debug] proxy_util.c(2193): proxy: connected ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:10 2012] [debug] mod_proxy_cluster.c(773): ajp_cping_cpong: Done

              [Mon Aug 27 09:22:10 2012] [debug] proxy_util.c(2029): proxy: ajp: has released connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:16 2012] [debug] mod_manager.c(1667): manager_trans STATUS (/)

              [Mon Aug 27 09:22:16 2012] [debug] mod_manager.c(2323): manager_handler STATUS (C:/) processing: "JVMRoute=f261431e-7879-3c7e-9aec-f01bc9542c5d&Load=100"

              [Mon Aug 27 09:22:16 2012] [debug] mod_manager.c(1404): Processing STATUS

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2011): proxy: ajp: has acquired connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2067): proxy: connecting ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2193): proxy: connected ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:16 2012] [debug] mod_proxy_cluster.c(773): ajp_cping_cpong: Done

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2029): proxy: ajp: has released connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:16 2012] [debug] mod_manager.c(2366): manager_handler STATUS  OK

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2011): proxy: ajp: has acquired connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2067): proxy: connecting ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2193): proxy: connected ajp://wlg-mafapweb05:8009/ to wlg-mafapweb05:8009

              [Mon Aug 27 09:22:16 2012] [debug] mod_proxy_cluster.c(773): ajp_cping_cpong: Done

              [Mon Aug 27 09:22:16 2012] [debug] proxy_util.c(2029): proxy: ajp: has released connection for (wlg-mafapweb05)

              [Mon Aug 27 09:22:17 2012] [debug] mod_proxy_cluster.c(1954): cluster: Found value kfgWYATYANH7eonwiuLLzShr.f261431e-7879-3c7e-9aec-f01bc9542c5d for stickysession JSESSIONID|jsessionid

              [Mon Aug 27 09:22:17 2012] [debug] mod_proxy_cluster.c(2338): cluster: Using route f261431e-7879-3c7e-9aec-f01bc9542c5d

              [Mon Aug 27 09:22:17 2012] [debug] mod_proxy_cluster.c(1543): proxy: byrequests balancer FAILED

              [Mon Aug 27 09:22:17 2012] [error] proxy: CLUSTER: (balancer://mycluster). All workers are in error state

              • 4. Re: mod_cluster issue after JBoss restart
                rhunt Newbie

                I have managed to resolve this issue by upgrading my mod_cluster binaries from 1.2.0.Final to the latest 1.2.2.Beta1 build from the Jenkins server at http://hudson.jboss.org/hudson/job/mod_cluster-windows/ - although I have no idea what may have changed to fix the problem.  Are there any non-Beta versions later than 1.2.0.Final I can try?  I'm guessing there's a 1.2.1 release out there somewhere but I can't find it anywhere to download.