3 Replies Latest reply on Feb 14, 2013 10:14 AM by foxwake

    Jboss7 LDAP configuration Problem

    foxwake Newbie

      I have a problem when configuring the ldap,

       

      Processing Failed:Search of baseDN(ou=people,dc=mycompany,dc=com) found no matches

      I have check and th user is uid=user,ou=people,dc=mycompany,dc=com

       

      any ideas?

       

      thanks in advance

       

      I have configure exactly like this

      <security-domain name="LDAP" cache-type="default">

                          <authentication>

                              <login-module code="org.jboss.security.auth.spi.LdapExtLoginModule" flag="required">

                                  <module-option name="java.naming.factory.initial" value="com.sun.jndi.ldap.LdapCtxFactory"/>

                                  <module-option name="java.naming.provider.url" value="ldap://10.10.10.10:389"/>

                                  <module-option name="bindDN" value="cn=Manager,dc=mycompany,dc=com"/>

                                  <module-option name="bindCredential" value="password"/>

                                  <module-option name="baseCtxDN" value="ou=people,dc=mycompany,dc=com"/>

                                  <module-option name="baseFilter" value="uid={0},ou=people,dc=mycompany,dc=com"/>

                                  <module-option name="rolesCtxDN" value="ou=groups,dc=mycompany,dc=com"/>

                                  <module-option name="roleFilter" value="(uniqueMember={0})"/>

                                  <module-option name="roleNameAttributeID" value="cn"/>

                                  <module-option name="roleAttributeIsDN" value="true"/>

                                  <module-option name="allowEmptyPasswords" value="false"/>

                                  <module-option name="Context.REFERRAL" value="follow"/>

                                  <module-option name="throwValidateError" value="true"/>

                              </login-module>

                          </authentication>

                      </security-domain>