3 Replies Latest reply on Aug 23, 2012 2:29 PM by slowdive

    SSL on JBoss AS7.1.1Final

    slowdive Newbie

      I am trying to configure SSL for my JBoss server. I'm starting small - just want to be able to view the JBoss splash screen. I have added the following to standalone.xml:

       

              <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false">
                  <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                  <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true">
                      <ssl/>
                  </connector>
                  <virtual-server name="default-host" enable-welcome-root="true">
                      <alias name="localhost"/>
                      <alias name="example.com"/>
                  </virtual-server>
              </subsystem>
      

       

      Whenever I try to access https://localhost:8443, I get "Unable to connect". What am I missing?

        • 1. Re: SSL on JBoss AS7.1.1Final
          Jay SenSharma Master

          Hi,

           

           

          You have placed <ssl/>  inside your connector where as there you are supposed to pass the keystore related infrmations... Try this:

           

          <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false">
              <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
          
              <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true">
                  <ssl name="ssl"
                       key-alias="chapter8"
                       password="rmi+ssl"
                       certificate-key-file="${jboss.server.config.dir}/chap8.keystore"
                       protocol="TLSv1"
                       verify-client="false"
                       certificate-file="${jboss.server.config.dir}/chap8.keystore"/>
              </connector>
          
              <virtual-server name="default-host" enable-welcome-root="true">
                  <alias name="localhost"/>
                  <alias name="example.com"/>
              </virtual-server>
          </subsystem>
          

           

           

          http://middlewaremagic.com/jboss/?p=2390

          • 2. Re: SSL on JBoss AS7.1.1Final
            slowdive Newbie

            Thanks Jay! I added the information for my keystore, and when I boot up, I get "Invalid Keystore Format". Is there any way I can specify the keystore type (PKCS12) and the provider? I didn't see that information here: http://docs.jboss.org/jbossweb/7.0.x/config/ssl.html

            • 3. Re: SSL on JBoss AS7.1.1Final
              slowdive Newbie

              Added keystore-type="PKCS12", and that resolved it.

              1 of 1 people found this helpful