1 Reply Latest reply on Apr 12, 2002 10:15 AM by Gerard Smyth

    Load Failed on large queries

    Gerard Smyth Newbie

      I recently changed from using Jboss 2.4.3 to 2.4.4, and I am now having trouble with code that worked fine with the older version. I am using CMP 1.1 for the entity beans, with the default Hypersonic database, but I am getting problems if a query returns a large number of entries (ie more than a few hundred!). If this is the case, when I iterate through the collection I get:

      Load failed; nested exception is: java.lang.NullPointerException

      at some random entry when I try and get any data from the bean. The size of the collection is correct, and for the entry at which i get an error, if i log the narrowed bean reference I get the bean type, and the primary key value, but calling any method gives the error!

      It also seems to take longer to get any data from the entity beans than with the previous version, and I getting much more out of memory errors with no stack trace. This can occur when the server is using about 80MB of memory, when there is 512 on the machine!

      Any help with how to fix these problems would be greatly appreciated, as I dont really know where to start as the code worked with the previous Jboss version!

      Cheers

      Gerard

        • 1. Re: Load Failed on large queries
          Gerard Smyth Newbie

          Sorry to ask again, but does anybody have any ideas as to what could be causing these problems?

          I need this to work for my university project, and i only have a couple of weeks left to complete it, so any help would be really appreciated!!

          The load failed errors only occur if a query returns large (ie a few hundred+ ) numbers of entries, they work fine for small results, and seem to occur for all queries whether automatically generated (eg findAll) or custom. I have tried changing the read ahead attribute with no change in the result!

          Thanks for your help!

          Gerard