10 Replies Latest reply on Aug 30, 2012 2:09 PM by Lincoln Baxter III

    No joy trying to get started with errai ui

    Michael Hirsch Newbie

      I've been trying for days now to get a basic errai-ui project off the ground, with no luck.  I must be doing something very wrong, but can't figure it out.

       

      I initially tried modifying my GWT app, but I've decided to start over.  No matter what I do I end up with missing dependencies and projects that won't load.

       

      First, I can't find any errai-ui maven archetypes.  All the archtypes use the old GWT way of rendering.

       

      The errai-UI demo that is well publicized on the web (http://vimeo.com/44141164) doesn't seem to actually work at all.  When I try to run it in dev mode with "mvn gwt:run" it appears to run, but the web page never loads.  It looks like there is no container running as there is nothing listening on port 8080.

       

      So I figured I'd start with something simple.  I used the "bus-quickstart" archetype like so: mvn archetype:generate -DarchetypeGroupId=org.jboss.errai.archetypes -DarchetypeArtifactId=bus-quickstart -DarchetypeVersion=2.1.0.Beta1 -DarchetypeRepository=https://repository.jboss.org/nexus/content/groups/public/

       

      This runs okay, but doesn't use errai-ui.  So I started by modifying the pom.xml to depend on errai-javaee-all, instead of the individual artifacts, and no other changes.  When I run this in dev mode I do see jetty starting up, but when I load the URL I get this error:

      EntryPoint initialization exception

       

       

      Exception while loading module org.jboss.errai.marshalling.client.api.MarshallerFramework. See Development Mode for details.

      java.lang.ExceptionInInitializerError

      at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:264)

      at com.google.gwt.dev.shell.ModuleSpace.loadClassFromSourceName(ModuleSpace.java:654)

      at com.google.gwt.dev.shell.ModuleSpace.onLoad(ModuleSpace.java:363)

      at com.google.gwt.dev.shell.OophmSessionHandler.loadModule(OophmSessionHandler.java:200)

      at com.google.gwt.dev.shell.BrowserChannelServer.processConnection(BrowserChannelServer.java:525)

      at com.google.gwt.dev.shell.BrowserChannelServer.run(BrowserChannelServer.java:363)

      at java.lang.Thread.run(Thread.java:722)

      Caused by: java.lang.RuntimeException:

      Deferred binding failed for 'org.jboss.errai.marshalling.client.api.MarshallerFactory' (did you forget to inherit a required module?)

      at com.google.gwt.dev.shell.GWTBridgeImpl.create(GWTBridgeImpl.java:53)

      at com.google.gwt.core.client.GWT.create(GWT.java:97)

      at org.jboss.errai.marshalling.client.api.MarshallerFramework.(MarshallerFramework.java:42)

      ... 8 more

      Caused by: com.google.gwt.core.ext.UnableToCompleteException: (see previous log entries)

      at com.google.gwt.dev.shell.ModuleSpace.rebindAndCreate(ModuleSpace.java:503)

      at com.google.gwt.dev.shell.GWTBridgeImpl.create(GWTBridgeImpl.java:49)

      ... 10 more

       

      This is quite similar to the errors I get when I tried to use errai-ui from scratch.  I get told that I'm missing imports, or that a method cannot be found.

       

      Does anyone have a simple errai-ui demo that works?  I would really appreciate seeing it actually work outside of a video.  I'm sure one I get it working I can modify it to my needs, but I'm starting to suspect that there is something wrong in the released jar files.

       

      Thanks,

       

      Michael