2 Replies Latest reply on Aug 30, 2012 5:39 AM by Dimitris Papangelis

    Bom's dependencies not picked up when running test phase in maven

    Dimitris Papangelis Newbie

      Hi there,

       

      I have been trying for quite some time now to get jms to work after migrating from as5 to as7. After looking up at the as7 quickstarts (helloworld-jms) i managed to make it work. The fact that i was based on the quickstarts means that i added the bom in my project's pom as well.

       

      The bom looks llike that:

       

      <dependency>

                                    <groupId>org.jboss.as</groupId>

                                    <artifactId>jboss-as-jms-client-bom</artifactId>

                                    <version>7.1.1.Final</version>

                                    <type>pom</type>

      </dependency>

       

       

      Everything works fine and my project can build and run with no problem at, but I recently started running the fest GUI tests that I have written and i get a ClassNotFoundException in org.jnp.interfaces.NamingContextFactory. I know that this comes from the quickstart's bom which means that during maven's test phase it doesnt get picked up in order to provide me with the classes that are needed. I (think) i confirmed this by adding jbossall-client as a dependency and that works fine with the tests. I also tried adding <scope>test</scope> in the bom and it doesnt seem to work either.

       

      Any ideas?

      thanks D.