0 Replies Latest reply on Aug 31, 2012 7:33 PM by markorocko

    Eclipse JBoss Tools hangs at startup while trying to fetch examples, blog, news resources

    markorocko Newbie

      I installed JBoss Tools with both Eclipse on Indigo and Juno so I can get up and running with AS7 QuickStarts.

      However, when I bring up JBoss Tools within Eclipse and JBoss Central comes up the Project Examples, News, and Blogs show spinning/loading icons and none of them resolve but keep spinning indefinitely while showing the message perpetually "Refreshing project examples".

      Then if I press cancel the system locks up.  Then if I reopen Eclipse it goes into this perpetual fetch mode and locks up.

      Before I load the notorious JBoss Tools Eclipse worked great. 

       

      I'm guessing perhaps the JBoss Tools wants to fetch files from the internet and unlike Eclipse itself which was able to download JBoss Tools. 

      My network uses a proxy.pac, I tried configuring the Network by typing in the proxy server values directly.  That didn't cure the woes.

      If I close JBoss Central and restart, Eclipse is functional again.

       

      I see these kind of messages in the error log:

      Invalid URL: http://download.jboss.org/jbosstools/examples/project-examples-category-jbosstools-3.3.xml

      Invalid URL: http://download.jboss.org/jbosstools/examples/project-examples-maven-3.2.xml

      java.net.SocketException: Reply from SOCKS server has bad version

          at java.net.SocksSocketImpl.connectV4(SocksSocketImpl.java:269)

          at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:437)

          at java.net.Socket.connect(Socket.java:529)

      !MESSAGE Could not load repository template extension contributed by org.jboss.tools.common.mylyn with connectorKind jira

       

      I'm going to try to run the tool outside of my companies network on wifi and see if I can confirm its the network but doesn't really help me.

      Any suggestions?