2 Replies Latest reply on Sep 6, 2012 12:20 PM by Dalibor Tokic

    Service does not start in JBoss 7

    Dalibor Tokic Newbie

      Hi,

       

      I have a Service (ImportService), which runs in PortalContainer scope and perfectly in GateIn 3.3 and JBoss AS 6.

      Here the ear-file:

      FSIntegration.ear

           |_> META-INF

           |_> PresentationPortlet.war

           |_> RestService.jar (this includes the conf/portal/configuration.xml)

           |_> lib

                 |_> jsoup-1.6.1.jar

                 |_> Shared.jar

           |_> TransformtionService.jar

       

      I adjusted the ear-file, so it can run in JBoss AS 7 and I deployed it in GateIn 3.3 and JBoss AS 7.

      Here is how the ear-file looks like:

       

      FSIntegration.ear

           |_> META-INF

           |_> PresentationPortlet.war

           |_> lib

                 |_> jsoup-1.6.1.jar

                 |_>RestService.jar (this includes the conf/portal/configuration.xml)

                 |_>Shared.jar

           |_> TransformtionService.jar

       

      I have no errors during deployment of the ear-file. But the service won't start.

      What's wrong? Is it a problem, that I moved the jar-file with the service to the lib-directory?

       

      The only suspicous I could find in the log was this:

      11:33:18,068 WARN [org.exoplatform.services.resources] (MSC service thread 1-5) Cannot load and merge the bundle: Resource

       

      But I don't know, if this is related to my problem.

      Anyone an idea?