1 Reply Latest reply on Sep 6, 2012 4:19 AM by Bela Ban

    Infinispan: Broken Pipe: Does Not Match Own Cookie

    John Bickerstaff Newbie

      Hi,

       

      Getting the following error on my infinispan servers when attempting to write something to the remote cache.

       

      java.net.SocketException: ConnectionMap.Connection.readPeerAddress(): cookie read by 192.168.41.155:7800 does not match own cookie; terminating connection

          at org.jgroups.blocks.TCPConnectionMap$TCPConnection.readPeerAddress(TCPConnectionMap.java:513)

          at org.jgroups.blocks.TCPConnectionMap$TCPConnection.<init>(TCPConnectionMap.java:401)

          at org.jgroups.blocks.TCPConnectionMap$ConnectionAcceptor.run(TCPConnectionMap.java:253)

          at java.lang.Thread.run(Thread.java:662)

       

      I'm aware of this ticket: https://community.jboss.org/thread/175714

       

      However, the solution there is non-obvious.  It seems to have solved it for the person querying, but I can't see what solved it for him.

       

      I'm setting up an Infinispan POC.  Two VMware linux VMs - each with an infinispan instance.  I start them this way:

       

      ./startServer.sh -r hotrod -c minimal.xml

       

      They appear to start up ok, although I don't see any output to the console when they do.

       

      When I run some sample java code and attempt to "put" -- I get a stack trace that mentions a broken pipe and each infinispan instance throws errors referencing it's own IP address and "cookie read by xxx.xxx.xxx.xxx does not match own cookie; terminating connection.

       

      I'm running infinispan 5.1.5.FINAL on both VMs...

       

      Attaching config xml files and the sample code - as well as the stack traces.  The second jgroups config file is the same as the one attached - just different ip address for that server in the TCP section.

       

      Any assistance or hints will be appreciated!