1 Reply Latest reply on Sep 11, 2012 4:16 AM by helmut.at.work

    Undeploy of test.jar after 1 minute idle while debugging ...

    helmut.at.work Newbie

      Hi,

      Im working with the current Arquillian Release on JBossAS 7.1.

      When I put a breakpoint in a test methode for a EJB (DataRepositoryBean)   and wait for more then 60 seconds the container undeploys the test jar.

       

      {code}...

      16:44:53,586 INFO  [org.hibernate.tool.hbm2ddl.SchemaExport] (MSC service thread 1-3) HHH000230: Schema export complete

      16:44:53,653 INFO  [org.jboss.weld.deployer] (MSC service thread 1-6) JBAS016008: Starting weld service for deployment ixTest.jar

      16:44:54,342 INFO  [org.jboss.as.server] (management-handler-thread - 1) JBAS018559: Deployed "ixTest.jar" {code}

      Here was the breakpoint.

       

      {code}16:45:09,849 Information [de.systematik.ix.ejb.DataRepositoryTest] (pool-4-thread-1) Testing to add station ...{code}

      Now I wait for 1 minute.

       

      {code}16:45:55,715 INFO  [org.jboss.weld.deployer] (MSC service thread 1-9) JBAS016009: Stopping weld service for deployment ixTest.jar

      16:45:55,722 INFO  [org.jboss.as.jpa] (MSC service thread 1-9) JBAS011403: Stopping Persistence Unit Service 'ixTest.jar#ixEjbPU'

      16:45:55,723 INFO  [org.hibernate.tool.hbm2ddl.SchemaExport] (MSC service thread 1-9) HHH000227: Running hbm2ddl schema export

      16:45:55,726 INFO  [stdout] (MSC service thread 1-9) Hibernate: alter table JobDef drop constraint FK84906728158DBEB8

      ...{code}

       

       

      Does anybody know the reason or can suggest a workaround?

      Thank You!