3 Replies Latest reply on Sep 12, 2012 11:31 AM by Heiko Rupp

    Postgresql 9.2 unsupported

    Davide D'Alto Newbie

      Hi,

      I'm trying to use RHQ with posgres version and I have this error:

      Could not determine database existence: java.lang.Exception: Unknown or unsupported database: name=[postgresql], version=[9.2.0]

       

      Reading the documentation it seems it should be supported.

       

      Am I doing anything wrong?

       

      Thanks,

      Davide

        • 1. Re: Postgresql 9.2 unsupported
          Heiko Rupp Master

          I don't think you are doing anything wrong. The version of 8.2.4+ is only valid for the highest version of the database at the time of writing release notes :-) While one could automatically allow all newer versions, I think it makes sense to test the code first, as there may be incompatibilities ( I recall that e.g. some escape character handling in postgres had changed in the past and thus our code also needed some changes

           

          This is definitievely something we need to look into for RHQ 4.5

          • 2. Re: Postgresql 9.2 unsupported
            Davide D'Alto Newbie

            Thanks for the quick reply.

             

            If it's so strict, maybe it would make sense to update the documentaion with correct versions supported.

             

            Cheers,

            Davide

            • 3. Re: Postgresql 9.2 unsupported
              Heiko Rupp Master

              Well, I think it does not need to be that strict and have thus just committed a fix to allow for 9.2 and later 9.x versions. It is in master as commit 30c79967d069c9 in case you want to build from source.

              Otherwise RHQ 4.5 will have this included. We expect to have 4.5 out within this month.