7 Replies Latest reply on Sep 25, 2012 3:06 PM by Lincoln Baxter III

    Trouble loading page in IE -- could not replace element

    Michael Hirsch Newbie

      My first errai app works well in Firefox and Chrome on both windows and linux, but when I finally tested it in windows and IE if fails to load correctly.  The part of the page defined by my errai template is blank.  I finally managed to get the developer tools to catch an error and it says:

       

      Could not replace Element with [data-field=password] - Did you already @Insert or @Replace a parent Element?

       

      There is only one template with a datafield named "password" which looks like:

      <html>

      <head>

          <title></title>

      </head>

      <body>

          <div data-field="loginPanel"  id="loginPanel">

                    <p><label data-field="message"/>Log on to Your Account</p>

              <p><input data-field="userName" type="text" placeholder="User name"/></p>

              <p><input data-field="password" type="password" placeholder="password"/></p>

              <p><button data-field="login" class="authPanelButton">Login</button></p>

          </div>

      </body>

      </html>

       

      I'm confused as to how this could happen, or why no one else has seen this problem (according to my google search).

       

      I've added "ie8" to the list of user-agents to compile to.  I've even tried making it the only user agent.

       

      I'm usuing errai 2.1.0.CR1 and GWT 2.4.0.

       

      Has anyone seen this?  What am I doing wrong?

       

      Thanks,

       

      Michael