2 Replies Latest reply on Sep 17, 2012 12:50 PM by Alessio Soldano

    How to set eclipse/maven dependencies to make jbossws work?

    Matthias M. Newbie

      Hi,

       

      I'm trying to use the contents of org.jboss.ws.* (e. g. "@WebContext"), but I'm not able to use the contents in the classpath.

      I already did:

      • install the CXF relatead package on my server
      • run the junit tests (2 failures)

       

      Now when I try to add a dependency to the pom.xml, there is no package available like 'org.jboss.ws'. Furthermore no workaround worked for me.

      I even tried to manipulate the archive generation of the war file in the maven configuration like:

      {code:xml}

                          <archive>

                              <manifestEntries>

                                  <Dependencies>org.jboss.ws.api services export</Dependencies>

                              </manifestEntries> 

                          </archive>

      {/code:xml}

      I hoped using this workaround, I could simply use eclipse's classpath to import and use the .jar directly. But everytime (even if I only do an import) I get an exception during compilation like:

      "java.lang.IllegalArgumentException: The argument does not represent an annotation type"

       

      I'm searching for a solution, but the google- and stackoverflow-results won't help.

       

      Is this because of the modular approach of as7.1 or did I simply miss a trivial step to do?

       

      I use eclipse, jboss as 7.1.1, jbossws cxf 4.0.2, maven 3.0.2. Because of maven I feel rather restricted than helped out. But that's because I'm not used to it.

      If I forgot to mention something important, please let me know.

       

      I bet there are many people saying this is a stupid question, but I would be thankful for an answer anyway

       

      Greetings!