3 Replies Latest reply on Nov 20, 2012 4:56 AM by bmcd

    JON causing errors in SOA-P server log

    bmcd Newbie

      I've set up JON 3.1 to monitor SOA-P V5.3.  JON sees the server ok, with everything showing up as available.

       

      JON's Service Availability Refresh interval is set to 15 mins, and every 15 mins the SOA-P server log shows

       

      2012-09-13 15:40:34,825 ERROR [org.jboss.security.auth.spi.UsersRolesLoginModule] (WorkerThread#4[127.0.0.1:43870]) Failed to load users/passwords/role files

      java.io.IOException: No properties file: users.properties or defaults: defaultUsers.properties found

       

      SOA-P has soa-roles.properties set up with bmcd=JBossAdmin,HttpInvoker,user,admin and soa-users.properties with bmcd=passwd.

      The JON connection settings have been set to use this Principal and Credential.

       

      Why would the service refresh within JON cause the error in SOA-P yet still show everything as available (with a green tick beside it)? 

        • 1. Re: JON causing errors in SOA-P server log
          Bruce Li Newbie

          I have the same issue.

          • 2. Re: JON causing errors in SOA-P server log
            Bruce Li Newbie

            There is a wayto avoid this errors.

             

            Added the users/roles properties for the 'other' domain as below. The user in other-users.properties is 'sa=', which is the usr/pwd for the DefaultDS used by build-in DS.  After that, the exception is gone.

             

            <application-policy name="other"> <authentication> <login-module code="org.jboss.security.auth.spi.UsersRolesLoginModule" flag="required"> <module-option name="usersProperties">props/other-users.properties</module-option>  <module-option name="rolesProperties">props/other-roles.properties</module-option>  </login-module> </authentication> </application-policy>

            • 3. Re: JON causing errors in SOA-P server log
              bmcd Newbie

              Thanks Bruce.  I tried your solution but it made no difference, however it prompted me to have another look at this issue.  I found this article RedHat's Knowledge Solutions, dated 17th October 2012.

               

              https://access.redhat.com/knowledge/solutions/220343

               

              To stop the errors from logging go into JON's Administration page, Navigate to Administration > Configuration > Metric Collection Templates. Expand JBossAS5 > for each type of Datasource (No tx, local and tx) edit each template. Highlight "Connection Available?" and leaving the "Update Existing Schedules" checked select Disable. Wait 30 minutes and you should no longer see these errors in your EAP server.log.

               

              I tried this and it works, problem solved!