11 Replies Latest reply on Sep 18, 2012 12:04 PM by Andy Pickler

    JBoss Tools 4 Alpha 1 - doesn't install

    Andy Pickler Newbie

      OS: Ubuntu 12.04 64-bit

      JDK: OpenJDK 1.7_07 (for compiling projects)

      Eclipse JDK: Oracle JDK 1.7_07 (specified in eclipse.ini)

       

      I followed today's blog posting to install the new JBoss Tools 4 Alpha 1 build, but Eclipse doesn't find any updates.  The .log file in my workspaces folder has this entry:

       

      !ENTRY org.eclipse.equinox.p2.core 4 0 2012-09-17 10:41:12.334

      !MESSAGE Provisioning exception

      !STACK 1

      org.eclipse.equinox.p2.core.ProvisionException: No repository found at http://download.jboss.org/jbosstools/updates/JBossTools-4.0.0.Alpha1b.core/.

          at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.fail(AbstractRepositoryManager.java:393)

          at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:675)

          at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:96)

          at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)

          at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository.addChild(CompositeMetadataRepository.java:165)

          at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository.<init>(CompositeMetadataRepository.java:105)

          at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepositoryFactory.load(CompositeMetadataRepositoryFactory.java:122)

          at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(MetadataRepositoryManager.java:57)

          at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:758)

          at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:651)

          at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:96)

          at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)

          at org.eclipse.equinox.p2.ui.ProvisioningUI.loadMetadataRepository(ProvisioningUI.java:412)

          at org.eclipse.equinox.internal.p2.ui.model.MetadataRepositoryElement.getMetadataRepository(MetadataRepositoryElement.java:120)

          at org.eclipse.equinox.internal.p2.ui.model.MetadataRepositoryElement.fetchChildren(MetadataRepositoryElement.java:70)

          at org.eclipse.equinox.internal.p2.ui.model.RemoteQueriedElement.fetchDeferredChildren(RemoteQueriedElement.java:34)

          at org.eclipse.ui.progress.DeferredTreeContentManager$1.run(DeferredTreeContentManager.java:235)

          at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

      !SUBENTRY 1 org.eclipse.equinox.p2.metadata.repository 4 1000 2012-09-17 10:41:12.335

      !MESSAGE No repository found at http://download.jboss.org/jbosstools/updates/JBossTools-4.0.0.Alpha1b.core/.

       

      Note...I did follow all the instructions in the blog entry, including downloading a fresh install of Eclipse Juno (for Java EE developers).