1 Reply Latest reply on Oct 12, 2012 12:18 PM by bug buster

    Admin Console not showing up in JBOSS 5.1.0 (some exception is thrown)

    bug buster Newbie

      I am trying to access the admin console  and its throwing an exception : I checked the components.xml but there is no webSession factory defined in that file.

      I am trying to find out where this webSession Factory is being created.

       

       

      Any ideas? what could be wrong?

       

       

       

       

      type Exception report

       

       

      message

       

       

      description The server encountered an internal error () that prevented it from fulfilling this request.

       

       

      exception

       

       

      java.lang.IllegalStateException: duplicate factory for: org.jboss.seam.web.webSession (duplicate is specified in components.xml)

                org.jboss.seam.core.Init.checkDuplicateFactoryExpressions(Init.java:227)

                org.jboss.seam.core.Init.checkDuplicateFactory(Init.java:220)

                org.jboss.seam.core.Init.addFactoryValueExpression(Init.java:283)

                org.jboss.seam.init.Initialization.installComponents(Initialization.java:1148)

                org.jboss.seam.init.Initialization.init(Initialization.java:737)

                org.jboss.seam.servlet.SeamListener.contextInitialized(SeamListener.java:36)

                org.jboss.on.embedded.LazyStartupListener.initialize(LazyStartupListener.java:182)

                org.jboss.on.embedded.LazyStartupListener.requestInitialized(LazyStartupListener.java:240)

                org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183)

                org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95)

                org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)

                org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)

                org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)

                org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)

                org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)

                org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)

                org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)

                org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451)

                java.lang.Thread.run(Thread.java:662)

       

       

       

      note The full stack trace of the root cause is available in the JBoss Web/2.1.10 logs.

        • 1. Re: Admin Console not showing up in JBOSS 5.1.0 (some exception is thrown)
          bug buster Newbie

          After reading a bit on Jboss Server, looks like the libraries I have added in the server's lib folder for seam dependencies(required by my custom apps) are also accesible by Jboss AS services like Admin-Console which also uses seam libraries internally.

          The only work around is to localize all the libraries and package them with the application. I am wondering if there is a way to configure the classpath such that only custom applications have access to the server's lib folder.Any ideas?