6 Replies Latest reply on Oct 2, 2012 10:18 AM by bart__

    Mod_jk and Jboss 7 domain configuration

    bart__ Newbie

      Hi,

       

      how can I configure jvmRoute attribute for use mod_jk and Jboss 7 in domain configuration?

       

      I have 2 server in cluster Jboss 7. There are 2 jvm for every server Jboss then 4 nodes in cluster.

       

      Thanks, Emanuele.

        • 1. Re: Mod_jk and Jboss 7 domain configuration
          Tomaz Cerar Master

          your are looking for node-id attribute in web subsystem.

           

           

           

          --

          tomaz

          • 2. Re: Mod_jk and Jboss 7 domain configuration
            bart__ Newbie

            Hi,

             

            I configure domain.xml in this way:

             

             

            <domain xmlns="urn:jboss:domain:1.3">

             

                <extensions>

            ......

                </extensions>

            <system-properties>

                    <property name="jvmRoute" value="nodeA"/>

            </system-properties>

             

            but I have 2 nodes (nodeA and nodeB) on the same server.

             

            How can i set instance-id for nodeB in domain.xml ?

             

             

            The settings that you suggested is as follows:


            <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false" instance-id="nodeA" >

             

            but i have the same problem.

             

            Emanuele.

             


            • 3. Re: Mod_jk and Jboss 7 domain configuration
              Tomaz Cerar Master

              then just do

               

              <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false" instance-id="${jvmRoute}" >

               

              given that jvmRoute is your system property.

               

              but by default we already have this in  place, aka if you dont set noting for instance-id (all never versions then 7.1.1 for 7.1.1 you should add instance-id="{jboss.node.name}" to your configuration) you can just set system property

              jboss.node.name

              and that is it, and this property defaults to host-name so you bascily don't need much more.

               

              --

              tomaz

              • 4. Re: Mod_jk and Jboss 7 domain configuration
                bart__ Newbie

                Where I set jboss.node.name ?

                 

                in host.xml ?

                • 5. Re: Mod_jk and Jboss 7 domain configuration
                  Tomaz Cerar Master

                  <host name="name-of-your-server" ....>

                  • 6. Re: Mod_jk and Jboss 7 domain configuration
                    bart__ Newbie

                    Sorry but I don't understand.

                     

                    I have this host.xml on master node:

                     

                    <host name="master" xmlns="urn:jboss:domain:1.3">

                     

                    <servers>

                            <server name="server-1_1" group="main-server-group">

                                <!-- Remote JPDA debugging for a specific server

                                <jvm name="default">

                                  <jvm-options>

                                    <option value="-Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n"/>

                                  </jvm-options>

                               </jvm>

                               -->

                             <socket-bindings socket-binding-group="ha-sockets" port-offset="150"/>

                         <jvm name="default"/>

                              

                            </server>

                            <server name="server-1_2" group="main-server-group" auto-start="true">

                                <!-- server-two avoids port conflicts by incrementing the ports in

                                     the default socket-group declared in the server-group -->

                                <socket-bindings socket-binding-group="ha-sockets" port-offset="250"/>

                                <jvm name="default">

                            </jvm>

                            </server>

                     

                    and this host.xml on slave node:

                     

                    <host name="slave" xmlns="urn:jboss:domain:1.3">

                     

                    <servers>

                            <server name="server-2_1" group="main-server-group"> 

                                <jvm name="default" />

                              <socket-bindings socket-binding-group="ha-sockets" port-offset="150"/>

                                <jvm name="default" />

                            </server>

                            <server name="server-2_2" group="main-server-group" auto-start="true">

                                <!-- server-two avoids port conflicts by incrementing the ports in

                                     the default socket-group declared in the server-group -->

                            <socket-bindings socket-binding-group="ha-sockets" port-offset="250"/>

                                 <jvm name="default"/>

                            </server>

                     

                    then I have 2 java process listening on two ajp port (one with offset 150 and other whi offset 250) on every server

                     

                    /opt/java/bin/java -D[Server:server-1_1] -XX:PermSize=256m -XX:MaxPermSize=256m -Xms64m -Xmx1G -server

                     

                    /opt/java/bin/java -D[Server:server-2_1] -XX:PermSize=256m -XX:MaxPermSize=256m -Xms64m -Xmx1G -server

                     

                    /opt/java/bin/java -D[Server:server-1_2] -XX:PermSize=256m -XX:MaxPermSize=256m -Xms64m -Xmx1G -server

                     

                    /opt/java/bin/java -D[Server:server-2_2] -XX:PermSize=256m -XX:MaxPermSize=256m -Xms64m -Xmx1G -server