1 Reply Latest reply on Oct 3, 2012 5:08 PM by João Bosco Monteiro

    java.lang.NoSuchFieldError: ENVIRONMENT with Forge 1.1.0 Final and Arquillian plugin

    João Bosco Monteiro Newbie

      Hi guys,

       

      I am facing the exception below following this guide http://arquillian.org/guides/get_started_faster_with_forge

       

      I am using Forge 1.1.0 (fresh install), Arquillian plugin, JBoss AS 7.1.1.Final (fresh install) and this profile:

       

      <profiles>

          <profile>

            <id>JBOSS_AS_MANAGED_7.X</id>

            <dependencies>

              <dependency>

                <groupId>org.jboss.as</groupId>

                <artifactId>jboss-as-arquillian-container-managed</artifactId>

                <version>7.1.2.Final</version>

              </dependency>

            </dependencies>

          </profile>

        </profiles>

       

       

      14:03:03,818 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC00001: Failed to start service jboss.deployment.unit.arquillian-service.INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit.arquillian-service.INSTALL: Failed to process phase INSTALL of deployment "arquillian-service"

                at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_35]

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_35]

                at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_35]

      Caused by: java.lang.NoSuchFieldError: ENVIRONMENT

                at org.jboss.as.arquillian.service.ArquillianService.addService(ArquillianService.java:88)

                at org.jboss.as.arquillian.service.ArquillianServiceActivator.activate(ArquillianServiceActivator.java:41)

                at org.jboss.as.server.deployment.service.ServiceActivatorProcessor.deploy(ServiceActivatorProcessor.java:62) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                ... 5 more

       

       

      Any advise?